Closed Bug 1009762 Opened 6 years ago Closed Last year

Intermittent unit-vh-vw-overflow-auto.html, textarea-focus.html | application crashed [@ mozilla::gl::ReadPixelsIntoDataSurface(mozilla::gl::GLContext*, mozilla::gfx::DataSourceSurface*)]

Categories

(Core :: Graphics: Layers, defect, P3, critical)

defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: crash, intermittent-failure)

Crash Data

https://tbpl.mozilla.org/php/getParsedLog.php?id=39583878&tree=Mozilla-Inbound

Android 4.0 Panda mozilla-inbound opt test plain-reftest-4 on 2014-05-13 10:34:21 PDT for push 22994a1e0af4
slave: panda-0617

10:55:15     INFO -  REFTEST TEST-START | http://10.12.134.17:30617/tests/layout/reftests/css-valuesandunits/unit-vh-vw-overflow-auto.html
10:55:15     INFO -  REFTEST TEST-LOAD | http://10.12.134.17:30617/tests/layout/reftests/css-valuesandunits/unit-vh-vw-overflow-auto.html | 451 / 1326 (34%)
10:55:15     INFO -  REFTEST TEST-LOAD | http://10.12.134.17:30617/tests/layout/reftests/css-valuesandunits/unit-vh-vw-overflow-auto-ref.html | 451 / 1326 (34%)
10:55:15     INFO -  INFO | automation.py | Application ran for: 0:09:23.806873
10:55:15     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmp6ASaaYpidlog
10:55:15     INFO -  Contents of /data/anr/traces.txt:
10:55:16     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android/1399999394/fennec-32.0a1.en-US.android-arm.crashreporter-symbols.zip
10:55:20  WARNING -  PROCESS-CRASH | http://10.12.134.17:30617/tests/layout/reftests/css-valuesandunits/unit-vh-vw-overflow-auto.html | application crashed [@ mozilla::gl::ReadPixelsIntoDataSurface(mozilla::gl::GLContext*, mozilla::gfx::DataSourceSurface*)]
10:55:20     INFO -  Crash dump filename: /tmp/tmpmvunld/05786196-9f2c-cbdc-0a67db5b-19034430.dmp
10:55:20     INFO -  Operating system: Android
10:55:20     INFO -                    0.0.0 Linux 3.2.0+ #2 SMP PREEMPT Thu Nov 29 08:06:57 EST 2012 armv7l pandaboard/pandaboard/pandaboard:4.0.4/IMM76I/5:eng/test-keys
10:55:20     INFO -  CPU: arm
10:55:20     INFO -       2 CPUs
10:55:20     INFO -  Crash reason:  SIGSEGV
10:55:20     INFO -  Crash address: 0x76600002
10:55:20     INFO -  Thread 38 (crashed)
10:55:20     INFO -   0  libxul.so!mozilla::gl::ReadPixelsIntoDataSurface(mozilla::gl::GLContext*, mozilla::gfx::DataSourceSurface*) [GLReadTexImageHelper.cpp:22994a1e0af4 : 280 + 0x4]
10:55:20     INFO -       r4 = 0x6d6e5cd0    r5 = 0x76600000    r6 = 0x76200000    r7 = 0x00001400
10:55:20     INFO -       r8 = 0x00000000    r9 = 0x00000000   r10 = 0x00000000    fp = 0x6d6e5d00
10:55:20     INFO -       sp = 0x6b17f998    lr = 0x633f0655    pc = 0x633f05f8
10:55:20     INFO -      Found by: given as instruction pointer in context
10:55:20     INFO -   1  libxul.so!mozilla::layers::CompositorOGL::CopyToTarget(mozilla::gfx::DrawTarget*, mozilla::gfx::Matrix const&) [CompositorOGL.cpp:22994a1e0af4 : 1389 + 0xd]
10:55:20     INFO -       r4 = 0x6b17fa30    r5 = 0x00000000    r6 = 0x6d6e5cd0    r7 = 0x00000000
10:55:20     INFO -       r8 = 0x6cff6100    r9 = 0x000002a0   r10 = 0x00000500    fp = 0x6b44dd90
10:55:20     INFO -       sp = 0x6b17fa00    pc = 0x63447cc1
10:55:20     INFO -      Found by: call frame info
10:55:20     INFO -   2  libxul.so!mozilla::layers::CompositorOGL::EndFrame() [CompositorOGL.cpp:22994a1e0af4 : 1235 + 0xb]
10:55:20     INFO -       r4 = 0x6b44dd90    r5 = 0x00000000    r6 = 0x6bbd4440    r7 = 0x6bbd4458
10:55:20     INFO -       r8 = 0x00000000    r9 = 0x00000000   r10 = 0x6423cf81    fp = 0x00000001
10:55:20     INFO -       sp = 0x6b17fa90    pc = 0x6344a1f3
10:55:20     INFO -      Found by: call frame info
10:55:20     INFO -   3  libxul.so!mozilla::layers::LayerManagerComposite::Render() [LayerManagerComposite.cpp:22994a1e0af4 : 460 + 0x5]
10:55:20     INFO -       r4 = 0x6b17fb08    r5 = 0x6b17fae8    r6 = 0x6bbd4440    r7 = 0x6bbd4458
10:55:20     INFO -       r8 = 0x00000000    r9 = 0x00000000   r10 = 0x6423cf81    fp = 0x00000001
10:55:20     INFO -       sp = 0x6b17faa8    pc = 0x6344465b
10:55:20     INFO -      Found by: call frame info
10:55:20     INFO -   4  libxul.so!mozilla::layers::LayerManagerComposite::EndTransaction(void (*)(mozilla::layers::ThebesLayer*, gfxContext*, nsIntRegion const&, mozilla::layers::DrawRegionClip, nsIntRegion const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags) [LayerManagerComposite.cpp:22994a1e0af4 : 248 + 0x5]
10:55:20     INFO -       r4 = 0x6bbd4440    r5 = 0x6d0dd000    r6 = 0x63430801    r7 = 0x6bb10000
10:55:20     INFO -       r8 = 0x6322c7d9    r9 = 0x6423cf81   r10 = 0x6423cf81    fp = 0x00000001
10:55:20     INFO -       sp = 0x6b17fb58    pc = 0x634447b5
10:55:20     INFO -      Found by: call frame info
10:55:20     INFO -   5  libxul.so!mozilla::layers::LayerManagerComposite::EndEmptyTransaction(mozilla::layers::LayerManager::EndTransactionFlags) [LayerManagerComposite.cpp:22994a1e0af4 : 199 + 0xb]
10:55:20     INFO -       r4 = 0x63444761    r5 = 0x6cff6100    r6 = 0x6bb101a8    r7 = 0x6bb10000
10:55:20     INFO -       r8 = 0x6322c7d9    r9 = 0x6423cf81   r10 = 0x6423cf81    fp = 0x00000001
10:55:20     INFO -       sp = 0x6b17fbb8    pc = 0x634399ad
10:55:20     INFO -      Found by: call frame info
Bug 1006198 touched this code very recently. Guessing it's related. Might also be bug 1003027 which landed earlier this month.
Blocks: 1006198
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(jgilbert)
Summary: Intermittent unit-vh-vw-overflow-auto.html | application crashed [@ mozilla::gl::ReadPixelsIntoDataSurface(mozilla::gl::GLContext*, mozilla::gfx::DataSourceSurface*)] → Intermittent unit-vh-vw-overflow-auto.html, textarea-focus.html | application crashed [@ mozilla::gl::ReadPixelsIntoDataSurface(mozilla::gl::GLContext*, mozilla::gfx::DataSourceSurface*)]
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(jgilbert)
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
With my work on bug 1243415 I can make that a perma failure when using ctx.DRAWWINDOW_USE_WIDGET_LAYERS for drawWindow().

https://treeherder.mozilla.org/#/jobs?repo=try&revision=7758e3f58733&filter-tier=1&filter-tier=2&filter-tier=3&selectedJob=32456548&bugfiler

Before the crash the following assertion is visible:

[Parent 1652] WARNING: Bad alignment for GLES. Will use temp surf for readback.: file /builds/slave/m-cen-m64-d-000000000000000000/build/src/gfx/gl/GLReadTexImageHelper.cpp, line 276
Assertion failure: readFormat == 0x1908, at /builds/slave/m-cen-m64-d-000000000000000000/build/src/gfx/gl/GLReadTexImageHelper.cpp:410
#01: DumpCompleteHeap[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x109eb47]
#02: DumpCompleteHeap[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x1042244]
#03: DumpCompleteHeap[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x10412b2]
#04: DumpCompleteHeap[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x1040dd6]
#05: DumpCompleteHeap[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x1067c01]
#06: DumpCompleteHeap[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x10666cd]
#07: DumpCompleteHeap[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x10665bd]
#08: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x9d6a19]
#09: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x6b9d5e]
#10: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x6b7c45]
#11: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x6b908d]
#12: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x6b9908]
#13: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x679bc7]
#14: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x67a614]
#15: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x67a81c]
#16: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x67b4c1]
#17: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x6798ac]
#18: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x6862d3]
#19: mozilla::net::LoadInfo::GetIsTopLevelLoad(bool*)[/builds/slave/test/build/application/NightlyDebug.app/Contents/MacOS/XUL +0x68652a]
#20: _pthread_body[/usr/lib/system/libsystem_pthread.dylib +0x405a]
#21: _pthread_body[/usr/lib/system/libsystem_pthread.dylib +0x3fd7]

For now I will disable using this flag, so after the landing of the patch you will be able to reproduce this crash with the following steps:

1. Open testing/marionette/capture.js and remove the comment for the flag
2. Run "mach marionette-test testing/marionette/harness/marionette/tests/unit/test_screenshot.py
Blocks: 1243415
Severity: normal → critical
Crash Signature: [@ mozilla::gl::ReadPixelsIntoDataSurface()] [@ mozilla::gl::ReadPixelsIntoDataSurface(mozilla::gl::GLContext*, mozilla::gfx::DataSourceSurface*)]
OS: Android → All
Hardware: ARM → All
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
Closing because no crash reported since 12 weeks.
You need to log in before you can comment on or make changes to this bug.