progess dlg crashes when trigger jars before previous one is finished

VERIFIED FIXED in M10

Status

Core Graveyard
Installer: XPInstall Engine
P3
critical
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: dougt, Assigned: dougt)

Tracking

Trunk
x86
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
Bug 5577 and 5579 have reported this problem.  Both of these test cases create
a folder, then add a bunch of files each having a append two-byte char.  (do
you remember the charset test in 4.5 - this is very similar).  When we go
across the thread boundary via proxy we crash in nsString2::Append.  Here is a
great stack trace:

Call Stack:    (Signature = MSVCRT.dll + 0xa64b (0x7800a64b) be16365b)
   MSVCRT.dll + 0xa64b (0x7800a64b)
   nsString::Assign
[d:\builds\seamonkey\mozilla\xpcom\ds\nsString2.cpp, line 877]
   nsString::nsString
[d:\builds\seamonkey\mozilla\xpcom\ds\nsString2.cpp, line 154]
   nsInstallProgressDialog::ItemScheduled
[d:\builds\seamonkey\mozilla\xpinstall\src\nsInstallProgressDialog.cpp, line
233]
   XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 135]
   EventHandler
[d:\builds\seamonkey\mozilla\xpcom\proxy\src\nsProxyEvent.cpp, line 325]
   PL_HandleEvent
[plevent.c, line 492]
   PL_ProcessPendingEvents
[plevent.c, line 453]
   _md_EventReceiverProc
[plevent.c, line 881]
   USER32.dll + 0x1250 (0x77e71250)
   nsappshell.dll + 0x17ec (0x011f17ec)
   apprunner.exe + 0x22f5 (0x004022f5)
   KERNEL32.dll + 0x1b304 (0x77f1b304)


I have not been able to reproduce this on 98.
(Assignee)

Updated

19 years ago
Blocks: 5577
(Assignee)

Updated

19 years ago
Blocks: 5579
(Assignee)

Updated

19 years ago
Depends on: 10177
(Assignee)

Updated

19 years ago
Target Milestone: M9
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 1

19 years ago
I can not reproduce this.  Marking as WORKS_FOR_ME.

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 2

19 years ago
Reopening since 5577 and 5579 have been reopened.  This bug is similar to those.

Updated

19 years ago
Resolution: WORKSFORME → ---

Comment 3

19 years ago
Clearing WorksForMe resolution due to reopen.

Updated

19 years ago
Component: XPInstall → Install Wizard

Comment 4

19 years ago
changing commponent to Install Wizard.
Component: Install Wizard → XPInstall
How can this be the install wizard, Sean? I'm changing it back to XPInstall

Comment 6

19 years ago
Jimmy commented in the meeting today, that if he click on several jars before
the previous one is finished, we will crash.

changing summary from "nsInstallProgressDialog is crashing on NT during
ItemScheduled." to "progess dlg crashes when trigger jars before previous one is
finished."

setting target milestone to M10
Summary: nsInstallProgressDialog is crashing on NT during ItemScheduled. → progess dlg crashes when trigger jars before previous one is finished
Target Milestone: M9 → M10
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
I just created 100 triggered installed, and everything went fine.  Lets regress
against m9.  Marking as FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
Crash with multiple files installed will be tracked in separate bug with a more
simpler test case.  Marking this bug verified.

Comment 9

18 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.