Closed Bug 1010124 Opened 7 years ago Closed 6 years ago

Accelerometer API not working on Nexus 10

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected
firefox32 --- affected
fennec + ---

People

(Reporter: cos_flaviu, Assigned: dougt)

References

Details

Attachments

(1 file)

484.57 KB, text/plain
Details
Environment: 
Device: Google Nexus 10 (Android 4.4.2);
Build: Nightly 32.0a1 (2014-05-13);

Steps to reproduce:
1. Launch Firefox;
2. Go to http://people.mozilla.com/~nhirata/html_tp/accel_bug615597.html
3. Tilt the device to move the black dot around.

Expected result:
The black dot moves with the device motion.

Actual result:
The black dot is fixed and does not move.
Any GeckoConsole errors? Is the event fired?
Component: General → DOM: Device Interfaces
Product: Firefox for Android → Core
Attached file logs
I attached the logs from logcat.
Did this regress?
tracking-fennec: --- → ?
Flags: needinfo?(flaviu.cos)
Regression window:
Last good build: 2012-03-14;
First bad build: 2012-03-15;
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c71845b3b2a6&tochange=d0d13f09be44
Flags: needinfo?(flaviu.cos)
Looks like a regression from bug 734391, assigning to dougt
Assignee: nobody → dougt
Blocks: 734391
tracking-fennec: ? → +
Summary: Gyroscope not working on Nexus 10 → Accelerometer API not working on Nexus 10
WFM on a nexus 5.  Is this device specific?
Keywords: qawanted
Nexus 10.
Keywords: qawanted
sorry for the delay.  sourcing now.
current Firefox Beta works for me.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Qawanted to verify
Keywords: qawanted
Using a flag for this.
Flags: qe-verify?
Keywords: qawanted
I'm unflagging this since the request has gone unanswered for several months. Please reflag this if you still want this verified.
Flags: qe-verify?
You need to log in before you can comment on or make changes to this bug.