RAP application does not start in Firefox 29

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: u52928, Unassigned)

Tracking

({regression, site-compat})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20140513 Firefox/24.0 (Nightly/Aurora)
Build ID: 20140513000503

Steps to reproduce:

This is definitely NOT how to file a bug, but I thought someone at Mozilla might like to know.
---------------------------------
I've just received an mail from one of the universities here in Berlin, Germany, where I teach informing users of the University system - long a champion of Fx - that version 29 "has a bug".

The following is my translation.
-----------------------------
Dear users of the BIS,

A few days ago the new Firefox release 29 was issued. For reasons I have not yet been able to ascertain, this release is incompatible with the BIS. After clicking the BIS Home icon, the user is told the BIS is being loaded. However, the actual web application doesn't load.

I'm assuming that this is a bug in Firefox that will hopefully be resolved in a timely manner. Since Firefox is usually updated in the background, this problem will probably affect all Firefox users for the foreseeable future. However, it only concerns version 29 of Firefox. There is no problem with Internet Explorer or Chrome.

I cannot say how long it will take Firefox to fix the error. Until then I would suggest using a different browser, such as Internet Explorer or Chrome.

If the Firefox problem is not resolved in a timely manner, I will implement a workaround at the BIS.

I apologize for the inconvenience.



Actual results:

Fx v. 29 didn't open


Expected results:

Fx v. 29 should have opened. open
The link to the site in question is https://forschung.beuth-hochschule.de/bis/beuth
Someone on the Fx Builds Forum kindly provided the following info.

TypeError: this._engineName is null rap-client.js:6
TypeError: rwt.widgets is undefined resources.js:14
TypeError: rwt.runtime.System is undefined
Version: 24 Branch → 29 Branch
This is because we removed window.controllers from the web-facing properties of the window object, and the rap-client.js script tries to read this in order to detect gecko. This is not a very clever thing to do, and this website shouldn't be doing it. We will not re-expose this object, and so the script will need to be fixed on their side.
Assignee: nobody → german
Status: UNCONFIRMED → NEW
Component: Untriaged → German
Ever confirmed: true
Keywords: site-compat
OS: Windows 7 → All
Product: Firefox → Tech Evangelism
Hardware: x86_64 → All
Version: 29 Branch → Trunk
The bug is in the eclipse RAP framework, and was fixed here:

http://git.eclipse.org/c/rap/org.eclipse.rap.git/commit/?id=827c1be3b8c47a005c5874ede232391b5c75ccb3

Can you inform the site maintainers of this fact and suggest that they could update? :-)
Flags: needinfo?(jgreenman)
(In reply to JoeG from comment #0)
> This is definitely NOT how to file a bug, but I thought someone at Mozilla
> might like to know.

Thank you for filing this. :-)
It's a good example that even a minor, useless interface could be used to detect UA, and the removal breaks the framework and the apps using it. Tweeted from FxSiteCompat:

https://twitter.com/FxSiteCompat/status/466590873892184064
https://www.facebook.com/FxSiteCompat/posts/640923725999470
https://plus.google.com/115208555324773750121/posts/4EKNi7c3jhB

I'll update the site compat doc soon to mention this:
https://developer.mozilla.org/en-US/Firefox/Releases/29/Site_Compatibility
Keywords: regression
Filed Bug 1010577 to add back window.controllers since it's widely used.
Summary: Firefox 29 doesn't work on University system → RAP application does not start in Firefox 29
Seems to work fine in in the latest Firefox 30 Beta 6 build (Build ID: 20140520115057) after the fix for bug 1010577 -  https://forschung.beuth-hochschule.de/bis/beuth loads without issues (does not load at all with 29.0.1 or 30 Beta 5).
RAP has provided a patch and Firefox 30 Beta 6 fixed Bug 1010577. Marking as RESOLVED.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jgreenman)
Resolution: --- → FIXED
Marking as Verified based on comment 8.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.