Closed Bug 1010140 Opened 6 years ago Closed 6 years ago

libffi dep builds fail to build for comm-central due to "IndexError: string index out of range" pymake error

Categories

(Thunderbird :: Build Config, defect)

All
Windows 7
defect
Not set
normal

Tracking

(thunderbird32 affected, thunderbird33 fixed)

RESOLVED FIXED
Thunderbird 33.0
Tracking Status
thunderbird32 --- affected
thunderbird33 --- fixed

People

(Reporter: standard8, Assigned: RyanVM)

References

Details

(Keywords: intermittent-failure, regression)

Libffi was updated in bug 810631.

For some reason it is failing to build on comm-central, I'm failing to understand what's happening.

https://tbpl.mozilla.org/php/getParsedLog.php?id=39635181&tree=Thunderbird-Trunk&full=1#error0

libtool: compile:  c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/msvcc.sh -DHAVE_CONFIG_H -I. -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi -I. -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/include -Iinclude -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/src -DFFI_DEBUG -O3 -Wall -c -showIncludes c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/src/debug.c -o src/debug.obj
cl -MDd -nologo -W3 -DHAVE_CONFIG_H -I. -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi -I. -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/include -Iinclude -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/src -RTC1 -c -showIncludes c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/src/debug.c -Fosrc/debug.obj -Fdsrc/debug -Fpsrc/debug -Fasrc/debug
debug.c
<all-am>: Found error
libtool: compile:  c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/msvcc.sh -DHAVE_CONFIG_H -I. -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi -I. -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/include -Iinclude -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/src -DFFI_DEBUG -O3 -Wall -c -showIncludes c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/src/closures.c -o src/closures.obj
cl -MDd -nologo -W3 -DHAVE_CONFIG_H -I. -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi -I. -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/include -Iinclude -Ic:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/src -RTC1 -c -showIncludes c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/src/closures.c -Fosrc/closures.obj -Fdsrc/closures -Fpsrc/closures -Fasrc/closures
closures.c
c:\builds\moz2_slave\tb-c-cen-w32-d-000000000000000\build\objdir-tb\mozilla\js\src\ctypes\libffi\Makefile:1573:0: command 'fail=; \
if (target_option=k; case ${target_option-} in ?) ;; *) echo "am__make_running_with_option: internal error: invalid" "target option '${target_option-}' specified" >&2; exit 1;; esac; has_opt=no; sane_makeflags=$MAKEFLAGS; if test -n 'Makefile src/.deps/closures.Plo src/.deps/debug.Plo src/.deps/java_raw_api.Plo src/.deps/prep_cif.Plo src/.deps/raw_api.Plo src/.deps/types.Plo src/aarch64/.deps/ffi.Plo src/aarch64/.deps/sysv.Plo src/alpha/.deps/ffi.Plo src/alpha/.deps/osf.Plo src/arc/.deps/arcompact.Plo src/arc/.deps/ffi.Plo src/arm/.deps/ffi.Plo src/arm/.deps/sysv.Plo src/arm/.deps/trampoline.Plo src/avr32/.deps/ffi.Plo src/avr32/.deps/sysv.Plo src/bfin/.deps/ffi.Plo src/bfin/.deps/sysv.Plo src/cris/.deps/ffi.Plo src/cris/.deps/sysv.Plo src/frv/.deps/eabi.Plo src/frv/.deps/ffi.Plo src/ia64/.deps/ffi.Plo src/ia64/.deps/unix.Plo src/m32r/.deps/ffi.Plo src/m32r/.deps/sysv.Plo src/m68k/.deps/ffi.Plo src/m68k/.deps/sysv.Plo src/m88k/.deps/ffi.Plo src/m88k/.deps/obsd.Plo src/metag/.deps/ffi.Plo src/metag/.deps/sysv.Plo src/microblaze/.deps/ffi.Plo src/microblaze/.deps/sysv.Plo src/mips/.deps/ffi.Plo src/mips/.deps/n32.Plo src/mips/.deps/o32.Plo src/moxie/.deps/eabi.Plo src/moxie/.deps/ffi.Plo src/nios2/.deps/ffi.Plo src/nios2/.deps/sysv.Plo src/pa/.deps/ffi.Plo src/pa/.deps/hpux32.Plo src/pa/.deps/linux.Plo src/powerpc/.deps/aix.Plo src/powerpc/.deps/aix_closure.Plo src/powerpc/.deps/darwin.Plo src/powerpc/.deps/darwin_closure.Plo src/powerpc/.deps/ffi.Plo src/powerpc/.deps/ffi_darwin.Plo src/powerpc/.deps/ffi_linux64.Plo src/powerpc/.deps/ffi_sysv.Plo src/powerpc/.deps/linux64.Plo src/powerpc/.deps/linux64_closure.Plo src/powerpc/.deps/ppc_closure.Plo src/powerpc/.deps/sysv.Plo src/s390/.deps/ffi.Plo src/s390/.deps/sysv.Plo src/sh/.deps/ffi.Plo src/sh/.deps/sysv.Plo src/sh64/.deps/ffi.Plo src/sh64/.deps/sysv.Plo src/sparc/.deps/ffi.Plo src/sparc/.deps/v8.Plo src/sparc/.deps/v9.Plo src/tile/.deps/ffi.Plo src/tile/.deps/tile.Plo src/vax/.deps/elfbsd.Plo src/vax/.deps/ffi.Plo src/x86/.deps/darwin.Plo src/x86/.deps/darwin64.Plo src/x86/.deps/ffi.Plo src/x86/.deps/ffi64.Plo src/x86/.deps/freebsd.Plo src/x86/.deps/sysv.Plo src/x86/.deps/unix64.Plo src/x86/.deps/win32.Plo src/x86/.deps/win64.Plo src/xtensa/.deps/ffi.Plo src/xtensa/.deps/sysv.Plo' && test -n '6'; then sane_makeflags=$MFLAGS; else case $MAKEFLAGS in *\\[\ \	]*) bs=\\; sane_makeflags=`printf '%s\n' "$MAKEFLAGS" | sed "s/$bs$bs[$bs $bs	]*//g"`;; esac; fi; skip_next=no; strip_trailopt () { flg=`printf '%s\n' "$flg" | sed "s/$1.*$//"`; }; for flg in $sane_makeflags; do test $skip_next = yes && { skip_next=no; continue; }; case $flg in *=*|--*) continue;; -*I) strip_trailopt 'I'; skip_next=yes;; -*I?*) strip_trailopt 'I';; -*O) strip_trailopt 'O'; skip_next=yes;; -*O?*) strip_trailopt 'O';; -*l) strip_trailopt 'l'; skip_next=yes;; -*l?*) strip_trailopt 'l';; -[dEDm]) skip_next=yes;; -[JT]) skip_next=yes;; esac; case $flg in *$target_option*) has_opt=yes; break;; esac; done; test $has_opt = yes); then \
  failcom='fail=yes'; \
else \
  failcom='exit 1'; \
fi; \
dot_seen=no; \
target=`echo all-recursive | sed s/-recursive//`; \
case "all-recursive" in \
  distclean-* | maintainer-clean-*) list='include testsuite man' ;; \
  *) list='include testsuite man' ;; \
esac; \
for subdir in $list; do \
  echo "Making $target in $subdir"; \
  if test "$subdir" = "."; then \
    dot_seen=yes; \
    local_target="$target-am"; \
  else \
    local_target="$target"; \
  fi; \
  (CDPATH="${ZSH_VERSION+.}:" && cd $subdir && C:/mozilla-build/python27/python.exe c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/build/pymake/pymake/../make.py 'AR_FLAGS=' 'CC_FOR_BUILD=' 'CFLAGS=-O3  -Wall' 'CXXFLAGS=-g' 'CFLAGS_FOR_BUILD=' 'CFLAGS_FOR_TARGET=' 'INSTALL=/usr/bin/install -c' 'INSTALL_DATA=/usr/bin/install -c -m 644' 'INSTALL_PROGRAM=/usr/bin/install -c' 'INSTALL_SCRIPT=/usr/bin/install -c' 'JC1FLAGS=' 'LDFLAGS=' 'LIBCFLAGS=' 'LIBCFLAGS_FOR_TARGET=' 'MAKE=C:/mozilla-build/python27/python.exe c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/build/pymake/pymake/../make.py' 'MAKEINFO=sh.exe /c/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/missing makeinfo  ' 'PICFLAG=' 'PICFLAG_FOR_TARGET=' 'RUNTESTFLAGS=' 'SHELL=sh.exe' 'exec_prefix=/usr/local' 'infodir=/usr/local/share/info' 'libdir=/usr/local/lib' 'mandir=/usr/local/share/man' 'prefix=/usr/local' 'AR=lib' 'AS=' 'CC=/c/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/msvcc.sh' 'CXX=/c/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/msvcc.sh' 'LD=link' 'NM=dumpbin -symbols' 'RANLIB=echo not_ranlib' 'DESTDIR=' $local_target) \
  || eval $failcom; \
done; \
if test "$dot_seen" = "no"; then \
  C:/mozilla-build/python27/python.exe c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/build/pymake/pymake/../make.py 'AR_FLAGS=' 'CC_FOR_BUILD=' 'CFLAGS=-O3  -Wall' 'CXXFLAGS=-g' 'CFLAGS_FOR_BUILD=' 'CFLAGS_FOR_TARGET=' 'INSTALL=/usr/bin/install -c' 'INSTALL_DATA=/usr/bin/install -c -m 644' 'INSTALL_PROGRAM=/usr/bin/install -c' 'INSTALL_SCRIPT=/usr/bin/install -c' 'JC1FLAGS=' 'LDFLAGS=' 'LIBCFLAGS=' 'LIBCFLAGS_FOR_TARGET=' 'MAKE=C:/mozilla-build/python27/python.exe c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/build/pymake/pymake/../make.py' 'MAKEINFO=sh.exe /c/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/missing makeinfo  ' 'PICFLAG=' 'PICFLAG_FOR_TARGET=' 'RUNTESTFLAGS=' 'SHELL=sh.exe' 'exec_prefix=/usr/local' 'infodir=/usr/local/share/info' 'libdir=/usr/local/lib' 'mandir=/usr/local/share/man' 'prefix=/usr/local' 'AR=lib' 'AS=' 'CC=/c/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/msvcc.sh' 'CXX=/c/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/msvcc.sh' 'LD=link' 'NM=dumpbin -symbols' 'RANLIB=echo not_ranlib' 'DESTDIR=' "$target-am" || exit 1; \
fi; test -z "$fail"' failed, return code 1
c:\builds\moz2_slave\tb-c-cen-w32-d-000000000000000\build\objdir-tb\mozilla\js\src\ctypes\libffi\Makefile:726:0: command 'C:/mozilla-build/python27/python.exe c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/build/pymake/pymake/../make.py 'AR_FLAGS=' 'CC_FOR_BUILD=' 'CFLAGS=-O3  -Wall' 'CXXFLAGS=-g' 'CFLAGS_FOR_BUILD=' 'CFLAGS_FOR_TARGET=' 'INSTALL=/usr/bin/install -c' 'INSTALL_DATA=/usr/bin/install -c -m 644' 'INSTALL_PROGRAM=/usr/bin/install -c' 'INSTALL_SCRIPT=/usr/bin/install -c' 'JC1FLAGS=' 'LDFLAGS=' 'LIBCFLAGS=' 'LIBCFLAGS_FOR_TARGET=' 'MAKE=C:/mozilla-build/python27/python.exe c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/build/pymake/pymake/../make.py' 'MAKEINFO=sh.exe /c/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/missing makeinfo ' 'PICFLAG=' 'PICFLAG_FOR_TARGET=' 'RUNTESTFLAGS=' 'SHELL=sh.exe' 'exec_prefix=/usr/local' 'infodir=/usr/local/share/info' 'libdir=/usr/local/lib' 'mandir=/usr/local/share/man' 'prefix=/usr/local' 'AR=lib' 'AS=' 'CC=/c/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/msvcc.sh' 'CXX=/c/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/js/src/ctypes/libffi/msvcc.sh' 'LD=link' 'NM=dumpbin -symbols' 'RANLIB=echo not_ranlib' 'DESTDIR=' all-recursive' failed, return code 2
c:\builds\moz2_slave\tb-c-cen-w32-d-000000000000000\build\mozilla\config\recurse.mk:154:0: command 'C:/mozilla-build/python27/python.exe c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/build/pymake/pymake/../make.py -C js/src/ctypes/libffi ' failed, return code 2
c:\builds\moz2_slave\tb-c-cen-w32-d-000000000000000\build\mozilla\config\rules.mk:598:0: command 'C:/mozilla-build/python27/python.exe c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/build/pymake/pymake/../make.py libs' failed, return code 2
c:\builds\moz2_slave\tb-c-cen-w32-d-000000000000000\build\objdir-tb\Makefile:52:0: command 'C:/mozilla-build/python27/python.exe c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/build/pymake/pymake/../make.py -C mozilla default' failed, return code 2
c:\builds\moz2_slave\tb-c-cen-w32-d-000000000000000\build\client.mk:391:0: command 'C:/mozilla-build/python27/python.exe c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/build/pymake/pymake/../make.py -j4 -C objdir-tb' failed, return code 2
c:\builds\moz2_slave\tb-c-cen-w32-d-000000000000000\build\client.mk:206:0: command 'C:/mozilla-build/python27/python.exe c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/mozilla/build/pymake/pymake/../make.py -f c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/client.mk build' failed, return code 2
Traceback (most recent call last):
  File "c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/build/pymake/make.py", line 35, in <module>
    main(sys.argv[1:])
  File "c:/builds/moz2_slave/tb-c-cen-w32-d-000000000000000/build/build/pymake/make.py", line 32, in main
    subprocess.check_call([sys.executable, PYMAKE] + args)
  File "C:\mozilla-build\python27\lib\subprocess.py", line 511, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['C:\\mozilla-build\\python27\\python.exe', 'c:\\builds\\moz2_slave\\tb-c-cen-w32-d-000000000000000\\build\\mozilla\\build\\pymake\\make.py', '-f', 'client.mk', 'build', 'MOZ_BUILD_DATE=20140514010208']' returned non-zero exit status 2
program finished with exit code 1
elapsedTime=1035.656000
The real error is:
  sh.exe: C:mozilla-buildmsysmozilla-buildpython27python.exe: command not found
and
  sh.exe: C:mozilla-buildmsysbuildsmoz2_slavetb-c-cen-w32-d-000000000000000buildmozillabuildpymakepymake..make.py: command not found
I know the problem. Patch coming.
I was expecting this bug to be waiting for me when I woke up this morning, because it occurred to me after I went to bed last night that when I re-added the older pymake hackarounds yesterday, I forgot about a new one that came up when working on bug 810631. Sorry :(

https://hg.mozilla.org/mozilla-central/rev/93e03b8c127e

New Windows builds have been triggered. I'll resolve this once c-c is confirmed green.
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird 32.0
Windows builds are green on c-c again and m-c is still green as well :)
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This got c-c building again, but there still appears to be issues with non-clobbers.

https://tbpl.mozilla.org/php/getParsedLog.php?id=39729262&tree=Thunderbird-Trunk

make.py[5]: Entering directory 'c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\objdir-tb\mozilla\js/src/ctypes/libffi'
Traceback (most recent call last):
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\make.py", line 35, in <module>
    pymake.process.ParallelContext.spin()
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\process.py", line 526, in spin
    c.run()
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\process.py", line 456, in run
    cb(*args, **kwargs)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 1403, in _cb
    self.usercb(error=False)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 895, in _commandcb
    self.commands.pop(0)(self._commandcb)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 1407, in __call__
    process.call(self.cline, loc=self.loc, cb=self._cb, context=self.context, **self.kwargs)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\process.py", line 258, in call
    cb(res=0)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 1403, in _cb
    self.usercb(error=False)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 895, in _commandcb
    self.commands.pop(0)(self._commandcb)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 1407, in __call__
    process.call(self.cline, loc=self.loc, cb=self._cb, context=self.context, **self.kwargs)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\process.py", line 258, in call
    cb(res=0)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 1403, in _cb
    self.usercb(error=False)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 895, in _commandcb
    self.commands.pop(0)(self._commandcb)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 1407, in __call__
    process.call(self.cline, loc=self.loc, cb=self._cb, context=self.context, **self.kwargs)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\process.py", line 267, in call
    command.main(argv[2:], env, cwd, cb)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\command.py", line 271, in main
    _MakeContext(makeflags, makelevel, workdir, context, env, targets, options, ostmts, overrides, cb)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\command.py", line 94, in __init__
    self.remakecb(True)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\command.py", line 124, in remakecb
    self.makefile.include(f)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 1786, in include
    stmts.execute(self, weak=weak)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\parserdata.py", line 987, in execute
    s.execute(makefile, context)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\parserdata.py", line 793, in execute
    makefile.include(f, self.required, loc=self.exp.loc, weak=self.weak)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 1786, in include
    stmts.execute(self, weak=weak)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\parserdata.py", line 987, in execute
    s.execute(makefile, context)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\parserdata.py", line 162, in execute
    self._execute(makefile, context)
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\parserdata.py", line 185, in _execute
    targets = [data.Pattern(p) for p in _expandwildcards(makefile, atargets)]
  File "c:\builds\moz2_slave\tb-c-cen-w32-00000000000000000\build\mozilla\build\pymake\pymake\data.py", line 580, in __init__
    nc = s[i + 1]
IndexError: string index out of range
Traceback (most recent call last):
  File "c:/builds/moz2_slave/tb-c-cen-w32-00000000000000000/build/build/pymake/make.py", line 35, in <module>
    main(sys.argv[1:])
  File "c:/builds/moz2_slave/tb-c-cen-w32-00000000000000000/build/build/pymake/make.py", line 32, in main
    subprocess.check_call([sys.executable, PYMAKE] + args)
  File "C:\mozilla-build\python27\lib\subprocess.py", line 511, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['C:\\mozilla-build\\python27\\python.exe', 'c:\\builds\\moz2_slave\\tb-c-cen-w32-00000000000000000\\build\\mozilla\\build\\pymake\\make.py', '-f', 'client.mk', 'build', 'MOZ_BUILD_DATE=20140515053028']' returned non-zero exit status 1
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Libffi fails to build for comm-central → libffi dep builds fail to build for comm-central due to "IndexError: string index out of range" pymake error
This should be fixed by bug 1021538. Not sure how easily we can backport that to comm-aurora, though?
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: Thunderbird 32.0 → Thunderbird 33.0
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #22)
> This should be fixed by bug 1021538. Not sure how easily we can backport
> that to comm-aurora, though?

Actually, it should be upliftable.
You need to log in before you can comment on or make changes to this bug.