Closed Bug 1010301 Opened 9 years ago Closed 9 years ago

[B2G]][Messaging App] Spinning icon when sending an sms and mms is not displayed

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.4 unaffected, b2g-v2.0 affected)

RESOLVED FIXED
2.0 S2 (23may)
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- affected

People

(Reporter: jschmitt, Assigned: azasypkin)

References

()

Details

(Keywords: regression, Whiteboard: [p=1][not-part-of-initial-sprint])

Attachments

(2 files)

Attached file log.txt
Description:
There is no spinning symbol when sending an sms or mms.

Repro Steps:
1) Update a Open_C to BuildID: 20140514040204
2) Open messaging app
3) Add a phone number to the Recipient list
4) Select in the 'Message' field and type a message
5) Select the 'Send' button

Actual:
There is no spinning icon when sending a message.

Expected:
The spinning icon is displayed when sending messages.

2.0 Environmental Variables:
Device: Open_C 2.0
BuildID: 20140514040204
Gaia: a13d42ab5240008e042d0c61bf9c9d05174e70e4
Gecko: 5c99d5136ad7
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL

Notes:
Repro frequency: 100%,
See attached: https://www.youtube.com/watch?v=_CF0H42dYQ8
Issue DOES repro on 2.0 Buri.

Issue does NOT repro on 1.4 Open_C.

1.4 Environmental Variables:
Device: Open_C 1.4
BuildID: 20140514000204
Gaia: b40103dec34a147c9018a1af76eb21c3184f2f93
Gecko: 7788969f70b0
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL
QA Contact: jmercado
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: msm7627a
BuildID: 20140513053655
Gaia: 45f8ee7409d638a84635647e2e5d375f3e131ef0
Gecko: 6ab2966b21cb
Version: 32.0a1

First Broken Environmental Variables:
Device: msm7627a
BuildID: 20140513063157
Gaia: f0aed88845112f77eae2e9dc4b24b35a121d33b3
Gecko: 165e4a0db0c5
Version: 32.0a1

Last Working gaia / First Broken gekko - Issue does NOT Reproduce
Gaia: 45f8ee7409d638a84635647e2e5d375f3e131ef0
Gecko: 165e4a0db0c5

First Broken gaia / Last Working gekko - Issue Reproduces
Gaia: f0aed88845112f77eae2e9dc4b24b35a121d33b3
Gecko: 6ab2966b21cb

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/45f8ee7409d638a84635647e2e5d375f3e131ef0...f0aed88845112f77eae2e9dc4b24b35a121d33b3
Oleg - Was this intentional or not?

bug 980461 seems to be the cause.
Flags: needinfo?(azasypkin)
(In reply to Jason Smith [:jsmith] from comment #3)
> Oleg - Was this intentional or not?
> 
> bug 980461 seems to be the cause.

Right it's because of bug 980461, where spinner color was changed to white per "download attachment" visual spec. That is why it's not visible on white background anymore. Let me check that with UX.

Hey Victoria, can you point me to VR spec for the spinner that should be shown while message is sending? The only one that looks related, I found in bug 980461 where the white spinner is used. Currently the same spinner element is shared between "downloading attachment" and "sending message" cases. But message bubbles aren't updated with new colors yet, so that is why white spinner isn't visible on white background.
Flags: needinfo?(azasypkin) → needinfo?(vpg)
(In reply to Oleg Zasypkin [:azasypkin] from comment #4)
> (In reply to Jason Smith [:jsmith] from comment #3)
> > Oleg - Was this intentional or not?
> > 
> > bug 980461 seems to be the cause.
> 
> Right it's because of bug 980461, where spinner color was changed to white
> per "download attachment" visual spec. That is why it's not visible on white
> background anymore. Let me check that with UX.
> 
> Hey Victoria, can you point me to VR spec for the spinner that should be
> shown while message is sending? The only one that looks related, I found in
> bug 980461 where the white spinner is used. Currently the same spinner
> element is shared between "downloading attachment" and "sending message"
> cases. But message bubbles aren't updated with new colors yet, so that is
> why white spinner isn't visible on white background.

Oleg, there are two spinners in Building Blocks, one is the white and the other is the usual light blue.

Please use the white over light green bubbles, and the blue over white bubbles.

(I would like to define a green one in the future "comms" theme, but that will be after this release.)

Thanks.
Flags: needinfo?(vpg)
(In reply to Victoria Gerchinhoren [:vicky] from comment #5)
> (In reply to Oleg Zasypkin [:azasypkin] from comment #4)
> > (In reply to Jason Smith [:jsmith] from comment #3)
> > > Oleg - Was this intentional or not?
> > > 
> > > bug 980461 seems to be the cause.
> > 
> > Right it's because of bug 980461, where spinner color was changed to white
> > per "download attachment" visual spec. That is why it's not visible on white
> > background anymore. Let me check that with UX.
> > 
> > Hey Victoria, can you point me to VR spec for the spinner that should be
> > shown while message is sending? The only one that looks related, I found in
> > bug 980461 where the white spinner is used. Currently the same spinner
> > element is shared between "downloading attachment" and "sending message"
> > cases. But message bubbles aren't updated with new colors yet, so that is
> > why white spinner isn't visible on white background.
> 
> Oleg, there are two spinners in Building Blocks, one is the white and the
> other is the usual light blue.
> 
> Please use the white over light green bubbles, and the blue over white
> bubbles.
> 
> (I would like to define a green one in the future "comms" theme, but that
> will be after this release.)
> 
> Thanks.

Thanks Victoria! Will take care of it.
Assignee: nobody → azasypkin
Blocks: sms-sprint-1
Status: NEW → ASSIGNED
Whiteboard: [p=1]
Target Milestone: --- → 2.0 S2 (23may)
Attachment #8423131 - Flags: review?(felash)
Bad UX fallout because there's no indication of progress anymore that the MMS is in progress of being sent.
blocking-b2g: --- → 2.0?
Comment on attachment 8423131 [details] [review]
GitHub pull request URL

r=me but please try to add a unit test; maybe next time someone changes this he'll think o testing it ;)
Attachment #8423131 - Flags: review?(felash) → review+
(In reply to Julien Wajsberg [:julienw] from comment #9)
> Comment on attachment 8423131 [details] [review]
> GitHub pull request URL
> 
> r=me but please try to add a unit test; maybe next time someone changes this
> he'll think o testing it ;)
Thanks! Added test and Travis is green.
Keywords: checkin-needed
(In reply to Oleg Zasypkin [:azasypkin] from comment #10)
> (In reply to Julien Wajsberg [:julienw] from comment #9)
> > Comment on attachment 8423131 [details] [review]
> > GitHub pull request URL
> > 
> > r=me but please try to add a unit test; maybe next time someone changes this
> > he'll think o testing it ;)
> Thanks! Added test and Travis is green.

master: https://github.com/mozilla-b2g/gaia/commit/a8fe2842ede448e9995d2ff86aedb9358d35db8d
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [p=1] → [p=1][not-part-of-initial-sprint]
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.