Closed Bug 1010378 Opened 6 years ago Closed 6 years ago

[B2G][Camera][Flame] Camera often freezes with red focus ring when switching back and forth between video and camera

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1007832

People

(Reporter: marcia, Unassigned)

References

()

Details

Attachments

(2 files)

Flame, while running:

Gaia   a13d42ab5240008e042d0c61bf9c9d05174e70e4
SourceStamp 5c99d5136ad7
BuildID 20140514040204
Version 32.0a1

STR:
1. Start the camera.
2. Try to take a picture

Observe various strange behavior:

**Many times I cannot even successfully take a picture since there is a large lag when switching between video and camera. **Often the camera app gets stuck with just the red focus ring showing like in the attached screenshot. When that happens, I can no longer take pictures until I relaunch the app.

Logcat and screenshots attached.
Better STR:
1. Make sure to switch to video first.
2. Start and video recording and then stop it
3. Switch back to camera and try to take a picture.
4. Observe the screenshot in the attachments.
QA Wanted - can we compare this against the old camera on 1.3 & get a video?
Keywords: qawanted
Added video URL showing the behavior on both 1.4 and Base 1.3 v10F-3.

This issue does NOT repro on Flame 1.3 Base Only
Environmental Variables:
Device: Flame 1.3
BuildID: 20140505215459
Gaia: ec462dc62979dae593b4ad96ac3851ccbafe1813
Gecko:
Version: 28.0
Firmware Version: v10F-3
Based on the updated STR, this is a duplicate of bug1007832 as that is the same method I used to reproduce/ensure resolved by patch.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1007832
You need to log in before you can comment on or make changes to this bug.