Closed Bug 1010418 Opened 6 years ago Closed 6 years ago

[B2G][Dialer] Answering a call from the Lockscreen then adding a contact to the call will bring the user to the homescreen

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T verified, b2g-v1.4 unaffected, b2g-v2.0 unaffected)

VERIFIED FIXED
2.0 S2 (23may)
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- verified
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected

People

(Reporter: jschmitt, Assigned: rik)

References

Details

(Keywords: regression, Whiteboard: [sprd313221])

Attachments

(4 files)

Attached file log.txt
Description:
Receiving a call on Lockscreen, answering then adding a contact will show the homescreen and the contacts app does not load.

Repro Steps:
1) Update a Tarako to BuildID: 20140514014003
2) Have the test device on lock screen
3) With a 2nd device call the test device
4) Answer the call on the test device
5) Select the 'phone' icon (3rd icon from the left)

Actual:
The phone does not open the contacts app.

Expected:
The contact app loads and user can add a contact to the call.

1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140514014003
Gaia: 53e2fcfe410c50a4a6ee38d27e8a8590d8460e00
Gecko: 9a6b5709d3ae
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29

Notes:
Repro frequency: 100%
See attached: screenshot, logcat
Attached image Dialer.png
Attached a screenshot of the issue.

Adding qawanted to test on 1.3 Buri.
Keywords: qawanted
QA Contact: croesch
Verified that in V1.3 Buri this bug DOES exist. User is NOT taken to the contacts app as expected.

Environmental Variables
Device: Buri V1.3
Build ID: 20140513024003
Gecko: https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/328611bdebc6
Gaia: 26a7a59d219fc8753613b433844123e428adcd56
Platform Version: 28.0
Firmware Version: v1.2-device.cfg
I have uploaded a youtube video of the issue.

https://www.youtube.com/watch?v=wb2j3_7r1gY
Attached image Open_C 1.4
this is the screenshot from Open_C 1.4 (same STR), apparently this is a global issue, repros across the board, on different devices and branches
This is a broken experience. We're too late for 1.3 & probably for Tarako as well, but we should try to get this into 1.4.
blocking-b2g: --- → 1.4?
Vance - Can you find out if TCL thinks this could be a cert blocker?
blocking-b2g: 1.4? → 1.4+
Flags: needinfo?(vchen)
Just adding that the issue also occurs on today's (5/16) master build:
Device: Hamachi
BuildId: 20140516065548
Gecko: 738f9f9
Gaia: 696257a
Platform version: 32.0a1
Hi Anthony,
Is this a bug belongs to dialer or lockscreen?
Flags: needinfo?(anthony)
I'm seeing two issues in this bug.

The first one reported (Place a new call takes you to homescreen instead of Dialer app on the Contacts tab) is probably a Dialer issue. I can't reproduce it on 1.4 or 2.0. I don't yet have a working Tarako so I can't check there on 1.3T. I'll ask qawanted with more specific STRs.

The second one is from comment 4. That one is dialer and lockscreen issue. The callscreen app should tell the lockscreen one that the user has unlocked the phone when answering. But the lockscreen should still stay lock if the user has a passcode. But since it has always been like that ever since we implemented the "place new call" feature, I don't think this is a 1.4+ blocker. And we should open another bug to fix this.
blocking-b2g: 1.4+ → ---
Repro Steps:
1) Update a Tarako to BuildID: 20140514014003
2) Have the test device on lock screen
3) With a 2nd device call the test device
4) Answer the call on the test device
5) Select the 'phone' icon (3rd icon from the left)
6) Unlock the screen

Actual:
The phone opens on the homescreen

Expected:
The dialer app loads on the contacts tab and user can add a contact to the call.

Does this reproduce on 1.4 and 2.0 ?
Flags: needinfo?(anthony)
Keywords: qawanted
(In reply to Anthony Ricaud (:rik) from comment #9)
> The second one is from comment 4. That one is dialer and lockscreen issue.
> The callscreen app should tell the lockscreen one that the user has unlocked
> the phone when answering. But the lockscreen should still stay lock if the
> user has a passcode. But since it has always been like that ever since we
> implemented the "place new call" feature, I don't think this is a 1.4+
> blocker. And we should open another bug to fix this.

This is not two separate issues. The same reporter both included STR & the video, which points to a bug that's pointing to what comment 2 points to. It doesn't make sense to me open a new bug - the STR & video describes a single problem ehre.

Also - That's a weak argument to not block. This was blocked on because this is an obvious bug that we would have not shipped with in 1.3 if we discovered it in time, as it's busted UX that results in a broken homescreen.
Keywords: qawanted
blocking-b2g: --- → 1.4+
(In reply to Anthony Ricaud (:rik) from comment #10)
> Repro Steps:
> 1) Update a Tarako to BuildID: 20140514014003
> 2) Have the test device on lock screen
> 3) With a 2nd device call the test device
> 4) Answer the call on the test device
> 5) Select the 'phone' icon (3rd icon from the left)
> 6) Unlock the screen
> 
> Actual:
> The phone opens on the homescreen
> 
> Expected:
> The dialer app loads on the contacts tab and user can add a contact to the
> call.
> 
> Does this reproduce on 1.4 and 2.0 ?

This is not the same bug. Please follow the original bug filed here that the reporter provided in the STR & the video.
I've watched the video and this is not the same issue… The video shows an empty screen with only the background. No lockscreen, no homescreen. The screenshot from comment 4 shows the lockscreen. My STRs are not the same, I agree, but I'd still want some qawanted to verify that 1.4 and 2.0 show the same issue:
"When pressing place a new call, only background picture is shown (no homescreen, no lockscreen)"

The fact that the lockscreen is displayed is annoying but once unlocked, the dialer app is shown and is actionable. Fixing this could have serious security regressions because we need to make sure that we don't bypass the passcode if it is set. So I think it is too risky to fix for 1.4.
Keywords: qawanted
Fair enough, but these are different bugs here. Let's stick what's originally filed in comment 0, which points to an issue on 1.3T & 2.0, not 1.4 & 1.3.

nkot - Can you open a separate bug for 1.3 & 1.3 behavior?

The QA Wanted request on comment 13 is out of scope on this bug, as the original bug as filed points to the issue seen on Tarako & 2.0. On that regard, I'm clearing the flag.

I'm also switching this to a 1.3T+ as this is a regression from the callscreen work.
blocking-b2g: 1.4+ → 1.3T+
Flags: needinfo?(vchen) → needinfo?(nkot)
Keywords: qawantedregression
(In reply to Jason Smith [:jsmith] from comment #14)
> Fair enough, but these are different bugs here. Let's stick what's
> originally filed in comment 0, which points to an issue on 1.3T & 2.0, not
> 1.4 & 1.3.
> 
> nkot - Can you open a separate bug for 1.3 & 1.3 behavior?

That should say 1.3 & 1.4 behavior.
Can we also reverify that the blank homescreen occurs on 1.3T & 2.0, but not 1.3 & 1.4?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #14)
> Fair enough, but these are different bugs here. Let's stick what's
> originally filed in comment 0, which points to an issue on 1.3T & 2.0, not
> 1.4 & 1.3.
>  […]
> The QA Wanted request on comment 13 is out of scope on this bug, as the
> original bug as filed points to the issue seen on Tarako & 2.0. On that
> regard, I'm clearing the flag.
I'm not seeing this bug on 2.0. And comment 0 is not talking about 2.0 either.
(In reply to Anthony Ricaud (:rik) from comment #17)
> (In reply to Jason Smith [:jsmith] from comment #14)
> > Fair enough, but these are different bugs here. Let's stick what's
> > originally filed in comment 0, which points to an issue on 1.3T & 2.0, not
> > 1.4 & 1.3.
> >  […]
> > The QA Wanted request on comment 13 is out of scope on this bug, as the
> > original bug as filed points to the issue seen on Tarako & 2.0. On that
> > regard, I'm clearing the flag.
> I'm not seeing this bug on 2.0. And comment 0 is not talking about 2.0
> either.

A bug like what's in comment 0 would be seen on 1.3T & 2.0 - it's talking about the new callscreen work.
Attached video 5_19_Master.3gp
Hi,

Attaching a video showing today's (5/19) master behavior:
Device: Hamachi
BuildId: 20140519095027
Gecko: d6d67da
Gaia: 9078b76
Platform version: 32.0a1

When selecting "add a participant" icon (3rd icon), the lock screen is displayed, once unlocked, the dialer app shows the list of contacts, and a contact can be selected and added.
I've verified that a blank homescreen is shown with the call at the top on Tarako V1.3 with the following variables

1.3 Environmental Variables:
Device: Tarako 1.3 MOZ
BuildID: 20140518013732
Gaia: 917174ee3812a43758bf43f7ba5f9416dcdb2ca8
Gecko: 7296746ab908
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29
*Update* the Firmware version for the Tarako in comment 20 is actually SP6821a-Gonk-4.0-5-12. Sorry about that we have a bug in our script that pulls the variables.

Which ones do we still need checked?
(In reply to croesch from comment #21)
> *Update* the Firmware version for the Tarako in comment 20 is actually
> SP6821a-Gonk-4.0-5-12. Sorry about that we have a bug in our script that
> pulls the variables.
> 
> Which ones do we still need checked?

No others - seems like this bug is tarako specific then.
Blocks: 990003
Tarako behavior is different from other devices and branches at one point - 1) the homescreen is shown when tapping icon to add a call, 2) if the user taps home button when on this screen, the lockscreen will be displayed. All other devices skips 1) and just go to the lockscreen directly. Once got to the lockscreen it's possible to unlock and see a Dialer app open on the Contacts tab on all devices including Tarako.

I have a video for that as well http://youtu.be/kOQLwuBPmy4

Should we still have another bug written up?
Flags: needinfo?(nkot)
Yes - this bug is tracking the tarako issue, while the other issue described above should be tracked separately.
Flags: needinfo?(nkot)
I'll look into this tomorrow. Although the main suspect for the regression is bug 990003, we have no evidence of that yet.
Assignee: nobody → anthony
Target Milestone: --- → 2.0 S2 (23may)
(In reply to Jason Smith [:jsmith] from comment #24)
> Yes - this bug is tracking the tarako issue, while the other issue described
> above should be tracked separately.

Okay, bug 1012889
Flags: needinfo?(nkot)
Adding window wanted to validate that bug 990003 is the cause.
QA Contact: croesch → jmercado
This issue occurs on the earliest Tarako 1.3T build available.  

Attempting to add another to the call will not bring up the contacts app.

Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140414111336
Gaia: 23488b1a45221c17e6a32fdd4c9d0fdbdcf2d021
Gecko: 72055108f470
Version: 28.1
Firmware Version: sp6821a-gonk-4.0-5-12
Hmm maybe not. Guess this just an issue that only so happens to be seen on Tarako then.
Keywords: regression
What we're seeing is the "lockscreen-disabled-cover". It has a data-z-index-level="lockscreen-disabled-cover" attribute that gives it a z-index: 10000, which means "be on top of everything".

It seems this was added in https://github.com/mozilla-b2g/gaia/commit/e2b1019efe2d6e1fd8fdff337d2187826f53f688 bug 982530 to fix a performance issue. It seems that with the work done in bug 990003 that landed after bug 982530, this is not needed anymore.

I've locally backed out e2b1019efe2d6e1fd8fdff337d2187826f53f688 and it seems to fix the issue here.

Greg: Do you expect any regression from backing out e2b1019efe2d6e1fd8fdff337d2187826f53f688 ?
Flags: needinfo?(gweng)
Blocks: 982530
No longer blocks: 990003
Keywords: regression
If the backout can fix this issue while the performance is good because of the bug 990003 as you described, I think the backout is worth and there should be no risk with that.

However I don't know whether the bug 990003 really fix the performance glitch or not, so I would verify that later locally.
Flags: needinfo?(gweng)
Whiteboard: [sprd313221]
Sorry I don't have chance to verify this today. I think it's OK to back it out. After all, I would be CCed again if the issue appears.
So the try build looks red but that's not a problem because we haven't worked on the test suites on tbpl for v1.3t and all try builds for v1.3t are red. The travis run is green so landing the backout.

https://github.com/mozilla-b2g/gaia/commit/4fd33d0264882f43920016acab774f0e56a6c5d8
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Depends on: 1014663
After following the provided STR, the contacts app is launched as expected. Verified fixed against latest v1.3T Tarako build:

v1.3T Environmental Variables:
Device: Tarako v1.3T MOZ RIL
BuildID: 20140523014001
Gaia: e76fc9fc64a027d84b2ec311fc624f4c3459dca9
Gecko: 52c1f97caee9
Version: 28.1
Firmware Version: SP6821A-Gonk-4.0-5-12
Status: RESOLVED → VERIFIED
(In reply to Anthony Ricaud (:rik) from comment #34)
> So the try build looks red but that's not a problem because we haven't
> worked on the test suites on tbpl for v1.3t and all try builds for v1.3t are
> red. The travis run is green so landing the backout.
> 
> https://github.com/mozilla-b2g/gaia/commit/
> 4fd33d0264882f43920016acab774f0e56a6c5d8
hi,there is still a call function 'enableWithoutCover()' in lockscreen.js .You didn't remove it clearly.
The call to enableWithoutCover() has caused bug 1014663.  

I think it must have been added by some other patch that built on top of the one Rik backed out.

We'll get that line removed in bug 1014663.
You need to log in before you can comment on or make changes to this bug.