Closed Bug 1010656 Opened 8 years ago Closed 8 years ago

[Tarako][Audio] Unable to play audio at background after making/answering a phone call during the audio being played

Categories

(Firefox OS Graveyard :: AudioChannel, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 1006356
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: bli, Unassigned)

Details

Environment:
-----------------------------------------------------
Gaia      dbc2b00f538df1d93960794fbb52aa84f6f19483
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/3b6c97b5fe8b
BuildID   20140514164005
Version   28.1
ro.build.version.incremental=eng.cltbld.20140514.202602
ro.build.date=Wed May 14 20:26:10 EDT 2014


Steps to reproduce:
-----------------------------------------------------
1. Play FM/Music

2. Make/Answer a phone call
   -->FM/Music cannot resume after hang up the call.

3. Launch FM/Music again
   -->FM/Music resume to play

4. Press home key to put FM/Music into background (or lock the screen)
   -->FM/Music stops, but does not get killed.
blocking-b2g: --- → 1.3T?

Per my investigation, the root cause should be as the same as bug 1006356. Because the visibility is affected by hidden_telephony audio channel. Once we encounter the bug 1006356 issue, the hidden telephony audio channel is occupied.

I try to disable the toneplayer init in keypad.js, and I can *not* duplicate this issue. Please see the comment 67 of bug 1006356. https://bugzilla.mozilla.org/show_bug.cgi?id=1006356#c67

    //TonePlayer.init('normal');
    //var channel = this._onCall ? 'telephony' : 'normal';
    //window.addEventListener('visibilitychange', (function() {
    //  TonePlayer.setChannel(document.mozHidden ? 'normal' : channel);
    //}).bind(this));

It can work on my device with the latest Gaia SW.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1006356
blocking-b2g: 1.3T? → ---
(In reply to Star Cheng [:scheng] from comment #1) 
> Per my investigation, the root cause should be as the same as bug 1006356.
> Because the visibility is affected by hidden_telephony audio channel. Once
> we encounter the bug 1006356 issue, the hidden telephony audio channel is
> occupied.
 
Got it. I'll re-test it after bug 1006356 being fixed.
Star, thanks for your help.
(In reply to Bingqing Li from comment #2)
> (In reply to Star Cheng [:scheng] from comment #1) 
> > Per my investigation, the root cause should be as the same as bug 1006356.
> > Because the visibility is affected by hidden_telephony audio channel. Once
> > we encounter the bug 1006356 issue, the hidden telephony audio channel is
> > occupied.
>  
> Got it. I'll re-test it after bug 1006356 being fixed.
> Star, thanks for your help.


Hi, Bingqing

The patch was landed. Could you help to re-test it?
Flags: needinfo?(bli)
Verified on build 20140518164003, audio can be played in background after a phone call, and the volume control works fine too.

Build Info
---------------------------------------------------------
Gaia      917174ee3812a43758bf43f7ba5f9416dcdb2ca8
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/7296746ab908
BuildID   20140518164003
Version   28.1
ro.build.version.incremental=eng.cltbld.20140518.200243
ro.build.date=Sun May 18 20:02:50 EDT 2014
Flags: needinfo?(bli)
(In reply to Bingqing Li from comment #4)
> Verified on build 20140518164003, audio can be played in background after a
> phone call, and the volume control works fine too.
> 
> Build Info
> ---------------------------------------------------------
> Gaia      917174ee3812a43758bf43f7ba5f9416dcdb2ca8
> Gecko    
> https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/7296746ab908
> BuildID   20140518164003
> Version   28.1
> ro.build.version.incremental=eng.cltbld.20140518.200243
> ro.build.date=Sun May 18 20:02:50 EDT 2014


Thanks!!
You need to log in before you can comment on or make changes to this bug.