Closed Bug 1010773 Opened 7 years ago Closed 7 years ago

Intermittent 766305.html | application crashed [@ mozalloc_abort(char const*)] ("ABORT: X_CreatePixmap: BadAlloc (insufficient resources for operation); 9 requests ago; id=0x12d")

Categories

(Core :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1005056

People

(Reporter: cbook, Unassigned)

References

()

Details

(Keywords: crash)

Ubuntu VM 12.04 mozilla-inbound opt test crashtest-ipc on 2014-05-14 20:33:07 PDT for push 8e40b976446f

slave: tst-linux32-spot-334

https://tbpl.mozilla.org/php/getParsedLog.php?id=39704488&tree=Mozilla-Inbound

TEST-UNEXPECTED-FAIL | file:///builds/slave/test/build/tests/reftest/tests/editor/libeditor/html/crashtests/766305.html | Exited with code 11 during test run
PROCESS-CRASH | file:///builds/slave/test/build/tests/reftest/tests/editor/libeditor/html/crashtests/766305.html | application crashed [@ mozalloc_abort(char const*)]

20:38:36     INFO -  Thread 0 (crashed)
20:38:36     INFO -   0  libmozalloc.so!mozalloc_abort(char const*) [mozalloc_abort.cpp:8e40b976446f : 30 + 0x0]
20:38:36     INFO -      eip = 0xb77271a9   esp = 0xbf921550   ebp = 0xbf921568   ebx = 0xb7728c24
20:38:36     INFO -      esi = 0xb75c4d9c   edi = 0xbf9215a8   eax = 0x0000000a   ecx = 0xffffffff
20:38:36     INFO -      edx = 0xb75c58ac   efl = 0x00210282
20:38:36     INFO -      Found by: given as instruction pointer in context
20:38:36     INFO -   1  libxul.so!NS_DebugBreak [nsDebugImpl.cpp:8e40b976446f : 435 + 0xe]
20:38:36     INFO -      eip = 0xb39e69fa   esp = 0xbf921570   ebp = 0xbf9219b8   ebx = 0xb6dde374
20:38:36     INFO -      esi = 0xbf9215b4   edi = 0xbf9215a8
20:38:36     INFO -      Found by: call frame info
20:38:36     INFO -   2  libxul.so!X11Error [nsX11ErrorHandler.cpp:8e40b976446f : 157 + 0x1d]
20:38:36     INFO -      eip = 0xb4bff7bc   esp = 0xbf9219c0   ebp = 0xbf9222d8   ebx = 0xb6dde374
20:38:36     INFO -      esi = 0xbf921a6c   edi = 0xbf921ac0
20:38:36     INFO -      Found by: call frame info
20:38:36     INFO -   3  libX11.so.6.3.0 + 0x39aca
20:38:36     INFO -      eip = 0xb29edacb   esp = 0xbf9222e0   ebp = 0xb729e000   ebx = 0xb2ae4ff4
20:38:36     INFO -      esi = 0xbf92231c   edi = 0xb2ae72e8
20:38:36     INFO -      Found by: call frame info
20:38:36     INFO -   4  libpthread-2.15.so + 0x9c38
20:38:36     INFO -      eip = 0xb770fc39   esp = 0xbf9222f0   ebp = 0xb729e000
20:38:36     INFO -      Found by: stack scanning
20:38:36     INFO -   5  libxcb.so.1.1.0 + 0x1fff3
20:38:36     INFO -      eip = 0xb2784ff4   esp = 0xbf9222f4   ebp = 0xb729e000
20:38:36     INFO -      Found by: stack scanning
20:38:36     INFO -   6  libxcb.so.1.1.0 + 0x1fff3
20:38:36     INFO -      eip = 0xb2784ff4   esp = 0xbf9222fc   ebp = 0xb729e000
20:38:36     INFO -      Found by: stack scanning
20:38:36     INFO -   7  firefox!arena_dalloc [jemalloc.c:8e40b976446f : 1649 + 0x8]
20:38:36     INFO -      eip = 0x0805a9a8   esp = 0xbf922310   ebp = 0xb729e000
20:38:36     INFO -      Found by: stack scanning
20:38:36     INFO -   8  libmozsqlite3.so!balance [sqlite3.c:8e40b976446f : 56942 + 0x6]
Missing the ABORT from the summary; also the exit code is normally surperfluous and causes false positives :-)
Summary: Intermittent 766305.html | Exited with code 11 during test run | application crashed [@ mozalloc_abort(char const*)] → Intermittent 766305.html | application crashed [@ mozalloc_abort(char const*)] ("ABORT: X_CreatePixmap: BadAlloc (insufficient resources for operation); 9 requests ago; id=0x12d")
Bah, wrong tab.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1005056
You need to log in before you can comment on or make changes to this bug.