JS strict warning fun (redeclarations) clicking "New Folder".

VERIFIED DUPLICATE of bug 67792

Status

SeaMonkey
Bookmarks & History
VERIFIED DUPLICATE of bug 67792
17 years ago
13 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Assigned: stephend@netscape.com (gone - use stephen.donner@gmail.com instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Warning: redeclaration of var firstSelected
Source File: chrome://communicator/content/bookmarks/bookmarksTree.js
Line: 656, Column: 12
Source Code:
        var firstSelected = seln.length ? seln[0] : gBookmarksShell.tree;

Warning: redeclaration of var folderType
Source File: chrome://communicator/content/bookmarks/bookmarksTree.js
Line: 657, Column: 12
Source Code:
        var folderType = firstSelected.getAttribute("type") == (NC_NS + "Folder");

Warning: redeclaration of var bItemCountCorrect
Source File: chrome://communicator/content/bookmarks/bookmarksTree.js
Line: 658, Column: 12
Source Code:
        var bItemCountCorrect = seln.length ? numSelectedItems == 1 : true;

Warning: redeclaration of var firstSelected
Source File: chrome://communicator/content/bookmarks/bookmarksTree.js
Line: 662, Column: 12
Source Code:
        var firstSelected = seln.length ? seln[0] : gBookmarksShell.tree;

Warning: redeclaration of var folderType
Source File: chrome://communicator/content/bookmarks/bookmarksTree.js
Line: 663, Column: 12
Source Code:
        var folderType = firstSelected.getAttribute("type") == (NC_NS + "Folder");

Warning: redeclaration of var bItemCountCorrect
Source File: chrome://communicator/content/bookmarks/bookmarksTree.js
Line: 664, Column: 12
Source Code:
        var bItemCountCorrect = seln.length ? numSelectedItems == 1 : true;

Warning: redeclaration of var seln
Source File: chrome://communicator/content/bookmarks/bookmarksTree.js
Line: 667, Column: 12
Source Code:
        var seln = gBookmarksShell.tree.selectedItems;

Warning: redeclaration of var flavourData
Source File: chrome://communicator/content/bookmarks/bookmarksDD.js
Line: 296, Column: 10
Source Code:
      var flavourData = aXferData.dataList[i].first;

Warning: redeclaration of var rSource
Source File: chrome://communicator/content/bookmarks/bookmarksDD.js
Line: 297, Column: 10
Source Code:
      var rSource = this.getResource(sourceID[i]);

Warning: redeclaration of var rParent
Source File: chrome://communicator/content/bookmarks/bookmarksDD.js
Line: 298, Column: 10
Source Code:
      var rParent = parentID[i] ? this.getResource(parentID[i]) : null;

*** This bug has been marked as a duplicate of 67792 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified up.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.