Closed Bug 1010984 Opened 7 years ago Closed 7 years ago

Builds without Firefox Health Report are unable to check for updates or update

Categories

(Firefox Health Report Graveyard :: Client: Desktop, defect)

defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached patch Add ifdefSplinter Review
Following bug 893098 landing, Thunderbird is not able to check for updates, and a bunch of our unit tests are failing due to:

6:21:33:315 | TEST-INFO | /builds/slave/talos-slave/test/build/xpcshell/tests/toolkit/mozapps/update/tests/unit_aus_update/urlConstruction.js | [run_test_pt1 : 45] testing url constructed with %PRODUCT% - http://localhost/%PRODUCT%/
06:21:33:315 | TEST-INFO | /builds/slave/talos-slave/test/build/xpcshell/tests/toolkit/mozapps/update/tests/unit_aus_update/head_update.js | [setUpdateURLOverride : 728] setting app.update.url.override to http://localhost/%PRODUCT%/
[4415] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file /builds/slave/tb-c-cen-osx64-d-0000000000000/build/mozilla/js/xpconnect/loader/mozJSComponentLoader.cpp, line 976
System JS : ERROR resource://gre/modules/UpdaterHealthProvider.jsm:13 - NS_ERROR_FILE_NOT_FOUND: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
TEST-UNEXPECTED-FAIL | xpcshell/head.js | NS_ERROR_XPC_CI_RETURNED_FAILURE: Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]
TEST-INFO | (xpcshell/head.js) | exiting test
TEST-INFO | (xpcshell/head.js) | test run_test_pt1 finished (2)

The problem is that UpdaterHealthProvider is being included even when the health report is disabled - so although the function that uses it is ifdeffed out, it still tries to load the module which tries to load other files, which fail, and then everything blows up.

The attached patch fixes the tests and allows Thunderbird to check for updates again.

I'll take whoever can review this first.
Attachment #8423140 - Flags: review?(robert.strong.bugs)
Attachment #8423140 - Flags: review?(enndeakin)
Comment on attachment 8423140 [details] [diff] [review]
Add ifdef

whoops, thanks for that.
Attachment #8423140 - Flags: review?(enndeakin) → review+
Attachment #8423140 - Flags: review?(robert.strong.bugs)
No longer blocks: 893098
Blocks: 893098
Standard8 pushed to mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/6d32bbffc7e4
Duplicate of this bug: 1011038
Opps,forgot to update.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.