download/saving file window frontmost blocks other tasks

RESOLVED DUPLICATE of bug 55977

Status

()

Core
Event Handling
--
minor
RESOLVED DUPLICATE of bug 55977
17 years ago
15 years ago

People

(Reporter: Bjarne D Mathiesen, Assigned: joki (gone))

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.4+) Gecko/20010921
BuildID:    0.9.4 & 2001092108

if the download/saving file window is frontmost...
1) no keyboard short-cut works
2) you can access the menus, but no action is taken

Reproducible: Always
Steps to Reproduce:
1. start downloading a file (eg latest build)
2. keep the "saving file" window frontmost
3a. try activating a menu item
3b. try using a keyboard short-cut

Actual Results:  nothing

Expected Results:  have activated at least the menu item

workaround : click in any other open task
But if "saving file" is the only window, Mozilla is effectively blocked from
doing anything until the download is completed

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 55977 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

15 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.