HTML select element cant be set using JavaScript in 0.9.4

VERIFIED FIXED

Status

()

VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: nosoup4u, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
This may be related to bug #97537.
I was using 0.9.0 (or 0.9.1 I cant remember - one before 0.9.4 anyway :), and
upgrated to 0.9.4.  Suddenly, my web app that used JS to populate form values
didnt work for SELECT elements.

Following is some code that reproduces my problem on 0.9.4:

<html>
<head>
<title>Javascript form population bug test</title>
</head>
<body>
<form name="testform">
<select name="testselect">
<option value="">Nothing</option>
<option value="1">One</option>
<option value="2">Two</option>
</select>
<br>
<input type="text" name="texttest" value="">
</form>
<script language="JavaScript">
document.forms["testform"].testselect.value="1";
document.forms["testform"].texttest.value="this works...";
</script>
</body>
</html>

I say that this may be related to bug #97537 in that they were both formally
working and both stopped working around the same verssion/time.
Hey, jkeiser, want to test this one with your changes too?  :)

Comment 2

17 years ago
I am unclear why this ever worked.  However, it's fixed in the upcoming patch
for bug 34297.  Adding dependency.
Status: UNCONFIRMED → NEW
Depends on: 34297
Ever confirmed: true

Comment 3

17 years ago
this one fails. i am attaching a testcase.

Comment 4

17 years ago
Created attachment 55842 [details]
testcase

Comment 5

17 years ago
this is a dup of bug 96346

Comment 6

17 years ago
Can't be a dup of that one, because this one fails and that one succeeds for me
on Linux 2001103113.

Comment 7

17 years ago
Fixed with bug 34297 landing.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
verified fixed. build 2001-12-07-10
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.