Closed Bug 1011146 Opened 7 years ago Closed 7 years ago

[B2G][System] Using edge gesture to swipe from fullscreen Youtube video results in top of header being cut off

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S2 (23may)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: bzumwalt, Assigned: etienne)

References

()

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

101.85 KB, text/plain
Details
46 bytes, text/x-github-pull-request
vingtetun
: review+
Details | Review
Attached file Logcat
Description:
When user swipes with edge gesture to different app while viewing fullscreen Youtube video, the app user swiped to has top of header cut off.

Repro Steps:
1) Updated Open C to BuildID: 20140515040207
2) Launch Settings (or any app with header that has text)
3) Return to homescreen and launch browser
4) Navigate to Youtube video and play video in fullscreen
5) Swipe from left edge of screen to switch to settings

Actual:
Swiping edge gesture from fullscreen youtube video results in cut off header.

Expected:
Header is not cut off after edge gesture swipe.

Environmental Variables:
Device: Open C v2.0 Master M-C Mozilla RIL
BuildID: 20140515040207
Gaia: 3a1d67246a79e3632c3b3f2460a25291e7e2714c
Gecko: e4843f4f08a7
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL

Notes:
Repro frequency: 3/3, 100%
See attached: Youtube video clip & logcat
Youtube video link: http://youtu.be/XZj4y_wItsQ

Adding QA Wanted for 2.0 Buri and 1.4
(In reply to Brogan Zumwalt from comment #1)
> Youtube video link: http://youtu.be/XZj4y_wItsQ
> 
> Adding QA Wanted for 2.0 Buri and 1.4

Don't worry about testing 1.4 here - this is a 2.0-specific feature.

Looks like the edge gesture transition is broken & we're not handling the case of transitioning from a fullscreen app to a non-fullscreen app cleanly.

Etienne - Any ideas on this?
blocking-b2g: --- → 2.0?
Flags: needinfo?(etienne)
Keywords: regression
Whiteboard: [systemsfe]
Assignee: nobody → etienne
Flags: needinfo?(etienne)
Attached file Gaia PR
Sending this one to Vivien since I already sent 2 to Alive :)
Attachment #8423415 - Flags: review?(21)
Keywords: qawanted
Removing regression keyword since this only happens if edge gestures is actually used.
Keywords: regression
https://github.com/mozilla-b2g/gaia/commit/752bf444524a16972d6de140bcef1f19dbcdc64b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-b2g: 2.0? → ---
blocking-b2g: --- → 2.0+
Target Milestone: --- → 2.0 S2 (23may)
blocking-b2g: 2.0+ → ---
feature-b2g: --- → 2.0
This is a bug in a preffed on feature, which should be using the blocking-b2g flag, not the feature-b2g flag.
blocking-b2g: --- → 2.0+
feature-b2g: 2.0 → ---
You need to log in before you can comment on or make changes to this bug.