If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Opening URL causes hard crash

RESOLVED DUPLICATE of bug 103461

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED DUPLICATE of bug 103461
16 years ago
7 years ago

People

(Reporter: Luke Hutchison, Assigned: Joe Chou)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Opening the page http://reled.byu.edu/ on Mozilla 0.9.4 causes a hard browser
crash after half a second or so.  The page has several Java applets on it.  I
don't know if this is related to the other Java problems people have been having
or not, but if it is, it's an extra page that can be examined to know what's wrong.

Comment 1

16 years ago
Works for me on 2001092208 WinME
wfm with win2k build 20010922..

Reporter:
Which JRE version are you using ? 
Can you give us a talkback ID ?
Severity: blocker → critical
Keywords: crash

Comment 3

16 years ago
wfm using build 2001092103 on Win2k with JRE 1.3.1.
(Reporter)

Comment 4

16 years ago
Broken on jre 1.3.0_01 / Mozilla 1.4 / RH 7.1 / GNOME 1.4.  I don't have a
Talkback build, but can a Linux Mozilla user with talkback please test it; if it
works for them I will install a talkback build to see if I can duplicate it there.

Comment 5

16 years ago
If you are crashing in Mozilla the best thing you can do to help the developers
fix your bug is to attach a stacktrace. If you're not building yourself you are
not out of luck.  Mozilla (thanks to a very cool donation from Netscape)
releases nightly and milestone builds with Full Circle's Talkback. Talkback
should catch most crashes and offer to send in a crash report. I can retrieve
that crash report and attach it to your bug report if you provide either the
Incident ID (you can get it by running the talkback program from
/components/talkback/) or you can let me know the email address you used to
submit the report and the time of sending. Thanks for your help in testing
Mozilla and reporting bugs.
Assignee: asa → av
Component: Browser-General → Plug-ins
QA Contact: doronr → shrir
(Reporter)

Comment 6

16 years ago
I'm afraid this crash seems to kill even the talkback client.  Talkback never
starts up.  The following info is printed in the terminal however:

# # An unexpected exception has been detected in native code outside the VM.#
Program counter=0x409444e8
#
# Problematic Thread: prio=1 tid=0x8458508 nid=0x6cc runnable 
#
INTERNAL ERROR on Browser End: Pipe closed during read? State may be corrupt
System error?:: Success

This is with Mozilla 0.9.4, talkback-enabled full installer.
Perhaps someone who knows more about Mozilla than me should try to get a
backtrace in their own browser.

Comment 7

16 years ago
Java applets --> OJI
Assignee: av → joe.chou
Component: Plug-ins → OJI

Comment 8

16 years ago
Need a stacktrace
Keywords: stackwanted

Comment 9

16 years ago
I also crash with 0.9.4 and 2001100809, java 1.3.0_01  ---> NEW

Unfortunately talkback is not triggered, although I have a talkback enabled
build. Mozilla produces the following output on the console before dying:

# # An unexpected exception has been detected in native code outside the VM.#
Program counter=0x4092a8d0
#
# Problematic Thread: prio=1 tid=0x8495c88 nid=0x4a8 runnable 
#
INTERNAL ERROR on Browser End: Pipe closed during read? State may be corrupt
System error?:: Success
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
QA Contact: shrir → pmac

Comment 10

16 years ago
Work for me on 20011001 on Solaris (trunk build)
(Reporter)

Comment 11

16 years ago
I heard that this was fixed in 0.9.5 but I just tried it and it's still broken.

Comment 12

16 years ago
I do not crash anymore with 0.9.5 ---> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

16 years ago
I just re-tested with 0.9.5, I was sure that it was still broken.  And it is. 
So I'm re-opening it.  It seems that something was fixed that remedied certain
installations of Mozilla (e.g. Diego Bierrun's), but it's still broken for at
least one (mine!).  Did anyone figure out whether the problem was related to the
JVM or to Mozilla?  If the former is true, it shouldn't be crashing Mozilla.  If
the latter is true, it's a bug that needs fixing, probably before 1.0.  I would
love to help debug but have no knowledge as to how to go about this.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 14

16 years ago
Hm, back at home I still crash with 0.9.5 and 2001102508. At my university the
Debian package of 0.9.5 has no problems. I get the following warnings at the
console from the page:

Warning: Cannot convert string "<Key>Escape,_Key_Cancel" to type VirtualBinding
Warning: Cannot convert string "<Key>Home,_Key_Begin" to type VirtualBinding
Warning: Cannot convert string "<Key>F1,_Key_Help" to type VirtualBinding
Warning: Cannot convert string "Shift<Key>F10,_Key_Menu" to type VirtualBinding
Warning: Cannot convert string "<Key>F10,Shift_Key_Menu" to type VirtualBinding
Warning: Cannot convert string "<Key>KP_Enter,_Key_Execute" to type VirtualBinding
Warning: Cannot convert string "Alt<Key>Return,Alt_Key_KP_Enter" to type
VirtualBinding

Comment 15

16 years ago
The errors on the console are identical, the other bug has an incident ID, so
this one's got to give..

*** This bug has been marked as a duplicate of 103461 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: pmac → petersen

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.