Closed Bug 1011341 Opened 5 years ago Closed 4 years ago

[B2G][Vendcom] The shopping cart icon in Nike does not take user to the shopping cart page

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 affected, b2g-v1.4 affected)

RESOLVED INVALID
Tracking Status
b2g-v1.3 --- affected
b2g-v1.4 --- affected

People

(Reporter: psiphantong, Unassigned)

References

()

Details

(Whiteboard: [openc-1.4-exploratory] [notcontactready])

Description:
When the user tap the shopping cart icon in Nike, the site does not go to the shopping cart page


Repro Steps:
1. Go to http://www.nike.com
2. Tap on the shopping cart icon


Actual:
the shopping cart icon does not take user to the items/shopping cart page


Expected:
the shopping cart icon take user to the items/shopping cart page


The issue occurs on the following devices:

1.4 Environmental Variables:
Device: Open_c 1.4 MOZ
BuildID: 20140515000202
Gaia: 2e97bee6bb79d3577dba1bf2a1bbfcba64ee99ab
Gecko: 0cb91945f404
Version: 30.0
Firmware Version: p821a10v1.0.0b06_log_dl


1.4 Environmental Variables:
Device: buri 1.4 MOZ
BuildID: 20140515000202
Gaia: 2e97bee6bb79d3577dba1bf2a1bbfcba64ee99ab
Gecko: 0cb91945f404
Version: 30.0
Firmware Version: v1.2-device.cfg

1.3 Environmental Variables:
Device: buri 1.3 MOZ
BuildID: 20140514024003
Gaia: 96e3fa769a436a2182e6d54088fb41386eb2b5b5
Gecko: 685cf1d0dedb
Version: 28.0
Firmware Version: v1.2-device.cfg

Was not able reproduce the issue on the following devices because when the user goes to Nike, the site crashes 

1.3 Environmental Variables:
Device: Open_c 1.3 MOZ Base Only
Firmware Version: p821a10v1.0.0b06_log_dl


1.3 Environmental Variables:
Device: Open_c 1.3 MOZ Base Only
Firmware Version: P821A10-ENG_20140410

1.4 Environmental Variables:
Device: Open_C 1.4
BuildID: 20140515000202
Gecko: 0cb91945f404
Version: 30.0
Firmware Version: P821A10-ENG_20140410
 
Repro frequency: 100%
See attached: Video, https://www.youtube.com/watch?v=v9kneft6Q3M
Component: Vendcom → Mobile
Product: Firefox OS → Tech Evangelism
Here nike.com sends the desktop version of their site to Firefox OS. I have trouble even loading it. Even when it does load, I can't find the shopping cart icon on the site I get - presumably they don't have online shopping in Norway?

Mike, I think I'll have to leave this to you..
Depends on: 1012483
I have filled bug 1012483, which is the first issue to test and solve before trying to get the shopping cart working.
Marking "notcontactready" until we've tried to make them solve that desktop content issue..
Whiteboard: [openc-1.4-exploratory] → [openc-1.4-exploratory] [notcontactready]
We get the mobile site and there's no shopping cart there at the moment..
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.