Closed Bug 1011509 Opened 7 years ago Closed 7 years ago

Provide a way to use 'let' and 'yield' keyword that is compatible with other browsers

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 855665

People

(Reporter: public, Unassigned)

Details

We all know 'let' and 'yield' aren't standard yet. According to http://kangax.github.io/compat-table/es6/ it's already possible to give them a try in IE11 and Safari6+, as well as latest Chrome with a special flag enabled... and in Firefox by adding 'type="application/javascript;version=1.7"' to script tags.

The problem is that adding this attribute prevents all other browsers to interpret the javascript. I'm pretty sure it is possible to find a way to let developers experiment with these keywords that is compatible with other browsers. A pref maybe?
Louis-Rémi: I think bug 855665 ("Enable let without version=1.8") will solve this issue.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 855665
You need to log in before you can comment on or make changes to this bug.