Closed Bug 1011682 Opened 6 years ago Closed 6 years ago

[B2G][Open_C][Clock] Stop, snooze buttons do not work and there is no sound or vibraton when alarm goes off

Categories

(Firefox OS Graveyard :: Gaia::Clock, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.3 unaffected, b2g-v1.3T unaffected, b2g-v1.4 fixed, b2g-v2.0 unaffected)

VERIFIED FIXED
2.0 S2 (23may)
blocking-b2g 1.4+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- unaffected
b2g-v1.4 --- fixed
b2g-v2.0 --- unaffected

People

(Reporter: jschmitt, Assigned: mcav)

References

Details

(Keywords: regression, smoketest)

Attachments

(3 files)

Attached image Alarm.png
Description:
The 'Stop', 'Snooze' buttons do not work and no sound/vibration. The user will have to restart the device.

Repro Steps:
1) Update a Open_C to BuildID: 20140516000201
2) Open the Clock app
3) Set an alarm
4) Proceed to Homescreen and force close the clock app from card view

Actual:
The 'Stop', 'Snooze' buttons do not work and no sound/vibration.

Expected:
The user can 'Stop', 'Snooze' the alarm and the sound/vibration is working.

1.4 Environmental Variables:
Device: Open_C 1.4
BuildID: 20140516000201
Gaia: 32fca83da31b9a0f9a5a88f96c913a25accdc14b
Gecko: a1e455367fa6
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL

Notes:
Repro frequency: 100%
See attached: logcat
Issue does not repro on 1.4 Buri, also does not repro on Master Open_C

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140516000201
Gaia: 32fca83da31b9a0f9a5a88f96c913a25accdc14b
Gecko: a1e455367fa6
Version: 30.0
Firmware Version: v1.2-device.cfg
Attached file log.txt
Adding qawanted to test on base Open_C
Keywords: qawanted
Correction, it worked yesterday so adding regression and regression window.
Note: the repro rate of this issue is ~75% not 100%, 3 out of 3 devices reproduced the bug, some from the first try, some from 2-5 tries.
blocking-b2g: --- → 1.4?
Keywords: qaurgent
QA Contact: jmitchell
I think this is the same problem as bug 1011612, which makes me think this is a build problem. I'm going to suggest that we retest this on the next build available to see if this still happens.
Keywords: qawanted
Can still reproduce on the 2nd build of the day.
1.4 Regression Window:

Last Working:
Environmental Variables:
Device: Open_C 1.4
BuildID: 20140515123001
Gaia: 8806eebe8f1555b1f924166f921ab831a5e3560c
Gecko: 366af94890cf
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL

First Broken:
Environmental Variables:
Device: Open_C 1.4
BuildID: 20140515183003
Gaia: 32fca83da31b9a0f9a5a88f96c913a25accdc14b
Gecko: a1e455367fa6
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL

Last Working Gaia First Broken Gecko: Issue DOES NOT reproduce
Gaia: 8806eebe8f1555b1f924166f921ab831a5e3560c
Gecko: a1e455367fa6

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 32fca83da31b9a0f9a5a88f96c913a25accdc14b
Gecko: 366af94890cf

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/8806eebe8f1555b1f924166f921ab831a5e3560c...32fca83da31b9a0f9a5a88f96c913a25accdc14b
Another regression due to bug 1010516.
Blocks: 1010516
Assignee: nobody → m
Duplicate of this bug: 1003418
I am unable to reproduce the issue on the latest Gaia/Gecko:

Gaia      8a2352d5b7be27ec4b1ea18c680ebcd0b6d34348
Gecko     https://hg.mozilla.org/mozilla-central/rev/cb9f34f73ebe
Assignee: m → nobody
(In reply to Marcus Cavanaugh [:mcav] <mcav@mozilla.com> from comment #10)
> I am unable to reproduce the issue on the latest Gaia/Gecko:
> 
> Gaia      8a2352d5b7be27ec4b1ea18c680ebcd0b6d34348
> Gecko     https://hg.mozilla.org/mozilla-central/rev/cb9f34f73ebe

You need to test this on 1.4. This issue doesn't reproduce on trunk - it's 1.4 specific.
Hm. Tested on 1.4 as well, still works as expected (buttons/vibration/etc work):

Your Target Build: PVT.v140.flame
URL:  https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g30_v1_4-flame-eng/latest/
ENG Ver: true
Flash: Gaia, Gecko,
Gaia      6edb70344916923b89f4cc3b603774904dea852c
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/08f6e7e0bc57
I see above that it was described as not being reproduced not every time, will try a few more times.
I just retested this on the latest 1.4 on Flame and was able to reproduce this on the 1st try.
I also got it to reproduce once -- but only once, that first time. I've since tested 15 times and cannot reproduce after that; I did see a potentially-interesting log ([JavaScript Error: "TypeError: Argument 3 of Window.postMessage can't be converted to a sequence."]) the first time, so I'm hoping I'll be able to isolate that if I can get it to reproduce once more.
(In reply to Marcus Cavanaugh [:mcav] <mcav@mozilla.com> from comment #15)
> I also got it to reproduce once -- but only once, that first time. I've
> since tested 15 times and cannot reproduce after that; I did see a
> potentially-interesting log ([JavaScript Error: "TypeError: Argument 3 of
> Window.postMessage can't be converted to a sequence."]) the first time, so
> I'm hoping I'll be able to isolate that if I can get it to reproduce once
> more.

I just reproduced this again & saw the same log:

E/GeckoConsole( 1715): [JavaScript Error: "TypeError: Argument 3 of Window.postMessage can't be converted to a sequence."]
E/GeckoConsole( 1715): Content JS WARN at app://clock.gaiamobile.org/js/onring.js:117 in consoleWarn: [l10n] #alarm is undefined.

The logcat attached also points to the same JS error too.
Ah, yes, that log must be a symptom of the cause. I reproduced again and saw the same thing. But there are no clock functions that pass more than two arguments to postMessage, so something's going funky. Still investigating.
Aha! Found the bug. It was a race condition in onring.js. The diff's fairly simple. This is why I don't use `.bind()` to curry parameters.

Thanks for your help, Jason.
Assignee: nobody → m
Status: NEW → ASSIGNED
Attachment #8425202 - Flags: review?(mmedeiros)
Target Milestone: --- → 2.0 S2 (23may)
blocking-b2g: 1.4? → 1.4+
Comment on attachment 8425202 [details]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/19405/commits

r=me. Changes are minimal and should not cause side effects. I also don't like bind.
Attachment #8425202 - Flags: review?(mmedeiros) → review+
Landed on v1.4, a=1.4+, r=millermedeieros:

https://github.com/mozilla-b2g/gaia/commit/3ae9aff662b4801b6354aa1633b95b168c90b393

As this is branch-specific, master doesn't need anything for this.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
No longer blocks: 1010516
Blocks: 1010516
No longer blocks: 1010516
Blocks: 1010516
Issue does not occur on today's 1.4 build on Open C

Verifying as fixed

Environmental Variables:
Device: Open C v1.4 Mozilla RIL
BuildID: 20140521000202
Gaia: 93623f6435849cc9f54d9996e8e64828ac9091d1
Gecko: 12fe2b67a099
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.