regression: crash closing window while loading image - Trunk [@ nsDocument::SetTitle]

VERIFIED FIXED in mozilla0.9.5

Status

()

Core
DOM: Core & HTML
--
critical
VERIFIED FIXED
16 years ago
7 years ago

People

(Reporter: Olivier Cahagne, Assigned: David Hyatt)

Tracking

({crash, topcrash})

Trunk
mozilla0.9.5
x86
Windows 2000
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments)

2.52 KB, text/plain
Details
1.52 KB, patch
Stuart Parmenter
: review+
Ben Goodger (use ben at mozilla dot org for email)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Build ID: 2001092208 on Win2k.
URL: http://www.mpa-garching.mpg.de/~ediscs/clusters/cl1238_L.jpg

Steps to reproduce:
 1. Load URL http://www.mpa-garching.mpg.de/~ediscs/clusters/cl1238_L.jpg
 2. While loading image, close it via Ctrl-W or by clicking on the appropriate
button in the title bar.
 3. Watch Mozilla crashing.

Talkback ID: T25759183K.

Expected behaviour: not crashing, I think it's a regression because it didn't
crash some weeks ago. I don't think it comes from this particular image because
I crash with other sites when I close the window too early. See bug 100279 for a
similar bug (not a dupe though as I first thought, the stacktraces don't seem to
be the same).

Comment 1

16 years ago
Confirmed 2001092214 linux. Preparing my debug build...
Keywords: crash

Comment 2

16 years ago
Created attachment 50447 [details]
GDB Backtrace 2001092302-debug linux

Comment 3

16 years ago
'event' is NULL.

nsDebug::Assertion(const char * 0x02472d58 `string', const char * 0x02472d9c
`string', const char * 0x02479f0c `string', int 649) line 290 + 13 bytes
nsDebug::PreCondition(const char * 0x02472d58 `string', const char * 0x02472d9c
`string', const char * 0x02479f0c `string', int 649) line 434 + 21 bytes
nsCOMPtr<nsIDOMEvent>::operator->() line 649 + 34 bytes
nsDocument::SetTitle(nsDocument * const 0x051603e0, const nsAString & {...})
line 2375 + 29 bytes
nsHTMLDocument::SetTitle(nsHTMLDocument * const 0x051603e0, const nsAString &
{...}) line 900
nsImageDocument::UpdateTitle() line 509 + 45 bytes
nsImageDocument::EndLayout(nsISupports * 0x00000000, unsigned int 2152398850)
line 437
ImageListener::OnStopRequest(ImageListener * const 0x051a2d68, nsIRequest *
0x054256e0, nsISupports * 0x00000000, unsigned int 2152398850) line 188
nsDocumentOpenInfo::OnStopRequest(nsDocumentOpenInfo * const 0x063f0200,
nsIRequest * 0x054256e0, nsISupports * 0x00000000, unsigned int 2152398850) line 257
nsStreamListenerTee::OnStopRequest(nsStreamListenerTee * const 0x054823f8,
nsIRequest * 0x054256e0, nsISupports * 0x00000000, unsigned int 2152398850) line 25
nsHttpChannel::OnStopRequest(nsHttpChannel * const 0x054256e4, nsIRequest *
0x0538e528, nsISupports * 0x00000000, unsigned int 2152398850) line 2220
nsOnStopRequestEvent::HandleEvent() line 162
nsARequestObserverEvent::HandlePLEvent(PLEvent * 0x050fef94) line 65
PL_HandleEvent(PLEvent * 0x050fef94) line 590 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0102ea70) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00140390, unsigned int 49560, unsigned int 0,
long 16968304) line 1071 + 9 bytes
USER32! 77e12e98()
USER32! 77e130e0()
USER32! 77e15824()
nsAppShellService::Run(nsAppShellService * const 0x01117f38) line 442
main1(int 1, char * * 0x00358378, nsISupports * 0x00000000) line 1278 + 32 bytes
main(int 1, char * * 0x00358378) line 1606 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e97d08()

Comment 4

16 years ago
this is from hyatt's change
Assignee: pavlov → hyatt
Component: ImageLib → DOM HTML
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.5
(Assignee)

Comment 5

16 years ago
Add a null-check to prevent crash.
(Assignee)

Comment 6

16 years ago
Created attachment 50449 [details] [diff] [review]
Null checks.

Comment 7

16 years ago
Comment on attachment 50449 [details] [diff] [review]
Null checks.

r=pavlov
Attachment #50449 - Flags: review+
Comment on attachment 50449 [details] [diff] [review]
Null checks.

sr=ben@netscape.com
Attachment #50449 - Flags: superreview+
(Assignee)

Comment 9

16 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 10

16 years ago
verified 2001092315 linux. thx =)

Comment 11

16 years ago
Verified fixed w2k build 2001-09-21-05-0.9.4
Status: RESOLVED → VERIFIED

Comment 12

16 years ago
Adding topcrash keyword and Trunk [@ nsDocument::SetTitle] for future reference,
as this *was* a topcrasher on the MozillaTrunk.
Keywords: topcrash
Summary: regression: crash closing window while loading image → regression: crash closing window while loading image - Trunk [@ nsDocument::SetTitle]

Comment 13

16 years ago
*** Bug 101540 has been marked as a duplicate of this bug. ***

Updated

9 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: tpreston → general
Crash Signature: [@ nsDocument::SetTitle]
You need to log in before you can comment on or make changes to this bug.