Closed Bug 1011780 Opened 6 years ago Closed 6 years ago

form autocomplete enter does not select form remembered suggestion

Categories

(Toolkit :: Autocomplete, defect)

29 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 286933

People

(Reporter: karolw, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

logging into a aws console, 
start typing previously selected string will show up as suggestion
down arrow to select (or not)
enter (key) submits the form instead of pick from offered suggestions.




Actual results:

forms keep submitting, you have to navigate with arrow keys to select


Expected results:

enter should have selected the offered suggestion to fill field in the form
Component: Untriaged → Autocomplete
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286933
You need to log in before you can comment on or make changes to this bug.