Closed Bug 1011818 Opened 8 years ago Closed 8 years ago

MozillaWiki on QA staging and dev has automated account creation test issues

Categories

(Websites :: wiki.mozilla.org, defect)

Beta
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: lizardwalk5, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.137 Safari/537.36

Steps to reproduce:

Running the automated test in test_create_user.py (from wiki-tests github repo) is resulting in test failures.

Impacts: wiki.allizom.org and wiki-dev.allizom.org

https://github.com/mozilla/wiki-tests/issues/53


Actual results:

Selenium script for creating valid user did not pass.


Expected results:

Expected the tests to pass. As a result of account creation page updates ... https://bugzilla.mozilla.org/show_bug.cgi?id=1008487 ... the automated test was not working. 
Would like a better communication process for wiki site changes that may impact automated testing. Also would like to find out who will administer the new account verification process (someone needs to OK new accounts and trigger sending password email for wiki staging and dev). QA can provide info about automated tests on wiki sites if related groups have questions.
Confirming the bug report (initially reported in github by chirarobert)

Error messages on running automated tests against wiki on dev environ.
Shows 4 tests are failing:
test_user_already_exists_error
test_passwords_mismatch_error
test_email_required_error
test_valid_email_required_error

Same error messages result when running the same test file on wiki staging environment.
Actually there are 5 tests that need to fail .
"test_create_valid_new_user" should also fail.
I just found out that our tests were running without "--destructive" command, and that test was not shown in the results
This is because bug 1008487 was recently implemented on dev.  We'll have to collectively figure out if account-creation is worth it (or even possible), given that the intent of that plugin is to make it hard/impossible for bots to register spam accounts...
Status: UNCONFIRMED → NEW
Ever confirmed: true
AndreiH's comments on expected failures on wiki staging and dev were merged.
The changes were tested and expected failures resulted for the 5 affected tests (create_test_user).
This is a temp fix to the question of how to test account creation. That discussion will be taken off the bug.
I will check the wiki working group's emails for possible flags to changes impacting qa tests.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.