Downloads continue in the background when d/l window is closed

VERIFIED FIXED in mozilla0.9.7

Status

()

Core
Networking
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Dennis Kehrig, Assigned: Bill Law)

Tracking

Trunk
mozilla0.9.7
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

Start a download, let it load a while, then cancel it. Close all active network
applications but leave a Mozilla window open. Then there is still traffic. The
file gets downloaded to c:\windows\temp. When going offline, the data is stored
under the file name originally selected (though it's incomplete). Obviously
cancelling a download should stop the download.

Reproducible: Always
Steps to Reproduce:
See description

Actual Results:  See description

Expected Results:  The download should have stopped directly after cancelling
it. Perhaps the user should be asked if the (incomplete) data should be deleted
or left on the hard disk (or in cache only, for resuming the download later).
wfm with win2k build 20010922..

I tried it 3x und the download stops always after I hit "cancel".
(Reporter)

Comment 2

17 years ago
Update: cancel != closing the window. Hit Alt+F4 or click the "X" button to
close the download window instead of clicking "cancel". Shame on me. Cancel
works for me, too.
Summary: Cancelled downloads continue in the background → Downloads continue in the background when d/l window is closed
setting status to new.  See discussion in bug 96891 on similar issues with a
different dialog.
Status: UNCONFIRMED → NEW
Ever confirmed: true
download dialog -> law
Assignee: neeti → law
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 5

17 years ago
*** Bug 85603 has been marked as a duplicate of this bug. ***
Blocks: 78106
(Assignee)

Comment 6

17 years ago
->0.9.7

Need to make onunload sort of like oncancel, but oncancel has risk of deleting
the temporary file.  So, moving out till I can ensure there's no bad side-effects.
Target Milestone: mozilla0.9.6 → mozilla0.9.7

Comment 7

17 years ago
*** Bug 111894 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

17 years ago
Created attachment 60702 [details] [diff] [review]
Patch to do onCancel logic from onclose handler
Comment on attachment 60702 [details] [diff] [review]
Patch to do onCancel logic from onclose handler

r=bryner
Attachment #60702 - Flags: review+

Comment 10

17 years ago
sr=hyatt
(Assignee)

Comment 11

17 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
qa -> me since I'm familiar with this one
QA Contact: benc → tever

Comment 13

17 years ago
verified:

Win98 2001-12-07-10-tr
Linux 2001-12-07-08-tr
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.