Closed Bug 101187 Opened 18 years ago Closed 18 years ago

This URL forces Javascript Engine and Mozilla into an infinite loop

Categories

(Core :: JavaScript Engine, defect, critical)

x86
All
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 13350

People

(Reporter: carljohan, Assigned: rogerl)

References

()

Details

(Keywords: hang)

Attachments

(1 file)

The URL above tries a lot of tests to crash different browsers,
and is succeeds in crashing Mozilla-0.9.4.

When viewing the page mozilla goes into an infinite loop and
becomes unresponsive, and ctrl-c is the only way out.

The part of the source that crashes mozilla is:

<SCRIPT>
var color = new Array;
color[1] = "white";
color[2] = "white";
for(x = 0; x <3; x++)
{
        document.bgColor = color[x]
        if(x == 2)
        {
                x = 0;
        }               
}
</SCRIPT>

A workaround is turning off javascript.
confirming with win2k build 20010922..
I can't attach a stack because my debug is still rebuilding....
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: hang
OS: Linux → All
Summary: This URL forces Javascript Engine and Mozilla into an infinite loop → This URL forces Javascript Engine and Mozilla into an infinite loop
Site seems to be down...

didn't we use to have infinite loop detection in place?
No we don't currently detect it, but it's filed as "DOM needs to police JS
infinite loops, schedule garbage collection"

*** This bug has been marked as a duplicate of 13350 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Marking Verified Duplicate - 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.