Closed Bug 1012195 Opened 6 years ago Closed 6 years ago

Android home panel icon size changed between Firefox 31 and 32

Categories

(Firefox for Android :: Awesomescreen, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: soeren.hentzschel, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image aurora-nightly.png
Please see the screenshot, left: the current Fennec Aurora (version 31), right: the current Fennec Nightly (version 32).
Blocks: lists
Thanks for the bug.

NI'ing Lucas/Margaret (as I don't know who adjusted this) to check whether this is expected or not and or a regression.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(margaret.leibovic)
Flags: needinfo?(lucasr.at.mozilla)
This is an intentional change from bug 1009473, which I want us to uplift.

However, this raises a point that we should document an expected image size for add-on developers to use. We made this change expecting images to be larger than the space available, but maybe we should handle centering images that are smaller, rather than stretching them to fill the space.
Blocks: 1009473
Flags: needinfo?(margaret.leibovic)
Oh, I see. For me the old image size was not too small but perfect. I saw the list view as a list with the focus on the headline of the entries not on the images. Now there is less space for text and in my opinion the headline is more important than the icon, especially if I can't read the categories of a feed to show differenct icons for different categories because nsIFeedEntry returns null in every case (bug 493175).
Flags: needinfo?(lucasr.at.mozilla)
(In reply to Sören Hentzschel from comment #3)
> Oh, I see. For me the old image size was not too small but perfect. I saw
> the list view as a list with the focus on the headline of the entries not on
> the images. Now there is less space for text and in my opinion the headline
> is more important than the icon, especially if I can't read the categories
> of a feed to show differenct icons for different categories because
> nsIFeedEntry returns null in every case (bug 493175).

Have you considered just not including an image? An image isn't required, and that would leave lots of room for text.
Yes, I considered not including an image, but to be honest it doesn't look great completely without images. If bug 493175 will not be fixed in the next weeks (and I don't think it will be fixed, last bug activity was in 2009) then I'll generate a json file on server-side and will load the json file instead of the feed, so that I can use different images, that's not a big problem. So the bigger "problem" is that I like the design with the old image size better, but that's probably a matter of taste.

What is the expected image size?
(In reply to Sören Hentzschel from comment #5)
> Yes, I considered not including an image, but to be honest it doesn't look
> great completely without images. If bug 493175 will not be fixed in the next
> weeks (and I don't think it will be fixed, last bug activity was in 2009)
> then I'll generate a json file on server-side and will load the json file
> instead of the feed, so that I can use different images, that's not a big
> problem. So the bigger "problem" is that I like the design with the old
> image size better, but that's probably a matter of taste.
> 
> What is the expected image size?

The image size is 95dp, which means that you should include images 190x190px to look good on 2dpi devices, and the image will be scaled down for devices with lower resolution. I will update the HomeProvider documentation to describe this.

I'm sorry that you prefer the old design, it's hard to choose a design that will work well for every use case, and we found in our testing that panels we were building looked better with bigger images, and with more whitespace around the text.

I agree the feed parser isn't great. I actually added some hacks to my own feed-based add-ons to look for images in the summary of the feed. Maybe this would help you:
https://github.com/leibovic/fennec_rss/blob/master/content/FeedHelper.js#L90
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.