Weirdness when creating new mail accounts

VERIFIED INVALID

Status

VERIFIED INVALID
17 years ago
10 years ago

People

(Reporter: deej, Assigned: sspitzer)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I've had trouble creating IMAP accounts that work and appear correctly. When I
first ran Mozilla 0.9.4, I ditched my existing Mozilla profile (it was an N6.1
profile) and re-imported my N4.78 profile.

The Mail/News panel came up with my email account, but it displayed some very
odd items, including "/Drafts", "/Sent" and a few others. This was in the IMAP
mailbox list, not the Local Folders list. I tried to use the "Subscribe" panel
to unsubscribe from them, but when I returned to the main Mail/News window they
were still listed. Going back into the Subscribe window, I could see that I was
still subscribed to these items and could not unsubscribe myself.

Next I tried removing them from my list, using the "Delete Folder" command in
the contextual menu that appears when you click-and-hold (ie: "right click") on
a folder in your folder list. Trying to delete them failed - the IMAP server
reported that they didn't really exist.

Finally, I tried to remove the account and create a new one, but it wouldn't
completely delete. There were three items in the Mail/News Account Settings window:

Mail for
Local Folders
Outgoing Server (SMTP)
The "Mail for" item was just that - one line on the left side of the pane, with
no sub-nested items like there usually are (eg: Server Settings, Addressing),
and there was no disclosure triangle. Selecting it did not enable the "Delete
Account" button.

I quit and re-launched Mozilla, but it didn't really help. I ended up deleting
my profile and starting again. I also shelled into my home directory
(telnet/ssh) and poked around. I removed two files, one called ".mailboxlist"
and one called ".mlbxtmp" (or something like that).

This went better, but there were two "INBOX" items listed. My IMAP mailbox list
was downloaded, and both "INBOX" items had the same number of unread messages
listed. I closed the Mail/News window and then re-opened it from the Tasks list,
and everything seemed normal.

One additional thing that has puzzled me is the presence of a "#news" item in my
IMAP folder list. It is greyed out and inside it are some subfolders
representing Usenet news "domains" (eg: alt, comp, etc). They don't appear to be
news groups I have ever subscribed to, and I don't understand why they appear in
my IMAP mailbox list, particularly as I have "mail/" in the IMAP Server Settings
> Advanced > IMAP Server Directory setting, so Mail/News shouldn't only be
looking in a folder that has only IMAP mailboxes.

Once again I was unable to remove "#news" from my mailbox list by using the
"Subscribe" tool - it basically just ignored me. I also couldn't find anything
in my home directory which is anything like that. In the end I renamed the
files".newsrc", ".oldnewsrc" and a folder called "News" in my home directory.
This seems to have solved the problem, but has rendered my Unix "rn"
non-operational.

Comment 1

17 years ago
deej, this is a very detailed and good bug-report, except that you describe a
bunch of different problems in the same bug-report.

Can you please file each problem as a separate bugreport, containing
reproducible steps, information about the build you are using etc.? Thank you.  

When you have re-filed the bugs. Please mark this bug INVALID.
(Reporter)

Comment 2

17 years ago
Asked to re-file individually.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
verified.  I've already seen the new #news bugged logged.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.