cannot enter https sites with Mozilla 0.9.4

VERIFIED FIXED in Future

Status

P3
critical
VERIFIED FIXED
17 years ago
2 years ago

People

(Reporter: xspuente, Assigned: ssaux)

Tracking

1.0 Branch
Future
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; ast-AS; rv:0.9.4) Gecko/2001091303

Cannot enter https sites, nor change master password. I'm using the Asturian
langpack, but it doesn't work if I start a new profile a choose en-US or el-GR
(Greek). It looks like this 0.9.4 release is lacking security files, or the
installation of a langpack (now they include pipnss and pippki as localized
items)is affecting security.
WFM 2001092208 on Win2k. 

Reporter: Please try a more recent build:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/
(and, be sure to delete your old Mozilla directory before installing the new one)
(Assignee)

Comment 2

17 years ago
Reporter let us know whether alex's suggestion helps.
Priority: -- → P3
Target Milestone: --- → Future
Version: 1.01 → 2.1
(Reporter)

Comment 3

17 years ago
It doesn't look to work with Mozilla 0.9.4 Build ID: 2001092403.

I get the following Windows error when starting the program the first time or
switch language:

It doesn't find the entering point for the procedure
?GetUnicode@nsString@@QBEPBGXZ in the dynamic link library xpcom.dll.

I don't know if that's the problem why then I cannot have any of the features of
PSM. I cannot see https sites or change master password,... with the brand new
installed Mozilla (English), or then, after installing the Asturian langpack.

I've found that Mozilla writes 3 files under WINNT: MozillaUninstall, Mozver and
nsreg (why doesn't write mozreg, as it should be?).

If it works for you, then it might be a problem with my system, but I've been
installing and uninstalling mozilla in the last 12 months, so it shouldn't be a
problem. The other thing I did this week was to install Virus Scan from Network
Associates, just for the record.
And, you deleted the old Mozilla/bin directory before installing the new one,
right? 

If that doesn't help, you may wish to try a fresh profile. You can manage/create
profiles with "mozilla.exe -profilemanager".
(Reporter)

Comment 5

17 years ago
Yes, I deleted the mozilla directory under program files, and under
administrator. Also the mozver and mozreg in winnt. I restarted the computer and
then I installed everything. I created 4 different profiles to test it. The only
thing I didn't do, and I usually do, is to clean windows registry for all
mozilla entries. Most of the times I do it, this time I didn't. Is it necessary?

Xose
Xose: That's probably not necessary, but you could try that.

If you still get that "xpcom" error, does that trigger Talkback?
(Reporter)

Comment 7

17 years ago
I don't have that error anymore. Only the first time I install Mozilla, or
everytime I install a language pack (I'm a l10n contributor). The error pops-up
just when Mozilla is starting, I have to click OK, and the it starts normally,
and I didn't notice anything strage until I tried to enter a https page, and
then try to change the master password.

The talkback doesn't do anything. And I think I didn't see any error on the console.
So, currently, HTTPS still doesn't work for you. Is that correct?
(Reporter)

Comment 9

17 years ago
Yes, they don't.
Ok, I can't reproduce this, but marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
From bug 101667:

Michael Kaply [2001-09-25 20:0]
"When I originally put up 0.9.4, it was missing https.

If you downloaded the first 0.9.4, and then grabbed the new one, 
delete XPTI*.dat in bin/components and component.reg in bin and then 
restart mozilla.

If security still doesn't work, please try creating a new profile."

Xose, give that a try :).

Comment 12

17 years ago
Well, our problem was OS/2 related, but this one is very interesting.

Can you place the entire content of the:

GetUnicode@nsString@@QBEPBGXZ in the dynamic link library xpcom.dll.

Message. It should also mention the DLL that was trying to load XPCOM.

In my experience, there is either an old XPCOM.DLL on your system, or a DLL from 
an older build that requires an older XPCOM.DLL. 

The second scenario is more likely.
(Reporter)

Comment 13

17 years ago
The error is as follows (I'm using Win2000Pro, Spanish version, so I translate
more or less the error):

The title of the error is:
NSPR:EventReceiver: mozilla.exe - The entry point procedure is not found

Then inside the error window it reads:

The entry point procedure is not found ?GetUnicode@nsString@@QBEPBGXZ in the
dynamic link library xpcom.dll

I tried to substitute my xpcom.dll for a new one extracted from a new downloaded
zip file, but still don't working.

Comment 14

17 years ago
Can you check to see if you have any other NSPR4.DLL or NSPR.DLK on your 
machine?
(Reporter)

Comment 15

17 years ago
I have installed Mozilla 0.9.2 (Build ID: 2001062815).

The security features work fine! I can enter https sites, change master
password,... And I don't have that wierd error after the installation. My system
and environment is the same, so I think there is a big problem with 0.9.4.
Although I don't understand why I seem to be the only one having this problem.

Xose
(Reporter)

Comment 16

17 years ago
I have the NSPR4.dll in C:\Program Files\Mozilla.org\Mozilla. But this is the
brand new working 0.9.2, I don't know if in 0.9.4 was.
(Reporter)

Comment 17

17 years ago
The problem disapeared with Build 2001092803. Everything related to security
works fine now. The .zip file installs OK, and the xpcom.dll problem doesn't
appear after installation. Marked as fixed.
Xose
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 18

17 years ago
Verified per reporter's comment.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.1 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.