If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

expanding all trees and then collapsing "appearance" tree causes segfault

VERIFIED DUPLICATE of bug 86723

Status

SeaMonkey
Preferences
--
critical
VERIFIED DUPLICATE of bug 86723
16 years ago
13 years ago

People

(Reporter: Nicole Zimmerman, Assigned: Samir Gehani)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010916
BuildID:    20010916

Expanding all of the trees in the preferences dialog box and then collapsing the
"appearance" tree causes a consistent segfault with the error message:

"Warning prev sibling is not in our list!!!"

Before the segfault it looks like the appearance text disappears or is jumbled
at the top, then it crashes.

It may also crash if you expand only one tree below "appearance" without
collapsing "appearance", but I did not do that much testing. I'll try after I
file the initial report. 

Reproducible: Always
Steps to Reproduce:
1. Go to Edit --> Preferences
2. Expand every tree (but do not collapse "appearance" tree).
3. Collapse "appearance" tree.
4. Boom.

Actual Results:  Segfault with the error above.

Expected Results:  Collapsed the tree with no segfault.
(Reporter)

Comment 1

16 years ago
It looks like if the scrollbar is created before trying to collapse the
"appearance" tree, this does not happen. So it only happens when expanding past
the size of the box that the preferences tree items appear in... and if the
scrollbar is created somehow before trying to collapse the tree, it doesn't
segfault. 

Just before it crashes, along with the text looking squished, the beginnings of
a scrollbar appear. 

Comment 2

16 years ago
This seems just a dup of Bug 86723
  Preference dialog crashes when changing category twisties 
yep, dup.

*** This bug has been marked as a duplicate of 86723 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: crash
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.