Closed Bug 1012796 Opened 8 years ago Closed 8 years ago

[B2G][Calendar] The 'All Day' and 'Day' events are overlapping on the month view.

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.4 unaffected, b2g-v2.0 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- affected

People

(Reporter: jschmitt, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached file log.txt
Description:
Having multiple All Day events and regular day events will cause overlapping on the month view.

Repro Steps:
1) Update a Open_C to BuildID: 20140519040204
2) Open 'Calendar' app
3) Proceed to the 'Day' view on the current day
4) Add two day event and two all day events
5) Select the 'Month' view

Actual:
The All Day events are overlapping the day events on the Month view.

Expected:
The events do not overlap.

2.0 Environmental Variables:
Device: Open_C 2.0
BuildID: 20140519040204
Gaia: 101c500903a2477f9de1ea5ce523b9e0be4d45d0
Gecko: 41a54c8add09
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL

Notes:
Repro frequency: 100%
Link to failed test case:
See attached: screenshot, logcat
Attached image Calendar
Issue repros on 2.0 Buri.

Issue does NOT repro on 1.4 Open_C

1.4 Environmental Variables:
Device: 1.4 Open_C
BuildID: 20140519000201
Gaia: defd0650fb9d30c6515d50a89e72d8fb74ce7e62
Gecko: d95594048b36
Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL
blocking-b2g: --- → 2.0?
Keywords: qaurgent
This is a bad bug, but I don't think this is a smoketest blocker because the smoketest requires creation of a single event, not 4 different events.

This is a regression from the month view visual refresh.
Gareth - Can you take a look?
Blocks: 951069
Flags: needinfo?(gaye)
Keywords: smoketest
Even though regressionwindow-wanted was removed, here is the window if needed.

B2G Inbound Regression Window

Last Working 
Environmental Variables:
Device:Open_C
BuildID: 20140515113003
Gaia: 7973e06dc278f67b4109ac3c33020ed086f0d042
Gecko: 15af5b93c0ea
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL

First Broken
Device: Open_C
BuildID: 20140515143028
Gaia: c0d92f9e1c0580208ee83a7f2db01e56c2c21490
Gecko: 4b08c59bde94
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: 7973e06dc278f67b4109ac3c33020ed086f0d042
Gecko: 4b08c59bde94

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: c0d92f9e1c0580208ee83a7f2db01e56c2c21490
Gecko: 15af5b93c0ea

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/7973e06dc278f67b4109ac3c33020ed086f0d042...c0d92f9e1c0580208ee83a7f2db01e56c2c21490
Blocks: 951075
No longer blocks: 951069
QA Contact: edchen
this happened because we landed the Day View before landing the Month View. - and we still did not land the Week View yet. (we said we would "break" things during the first few weeks on dev.gaia: https://groups.google.com/d/msg/mozilla.dev.gaia/dmU739T86cU/LKgmpqn6tMEJ)
Flags: needinfo?(gaye)
(In reply to Miller Medeiros [:millermedeiros] from comment #5)
> this happened because we landed the Day View before landing the Month View.
> - and we still did not land the Week View yet. (we said we would "break"
> things during the first few weeks on dev.gaia:
> https://groups.google.com/d/msg/mozilla.dev.gaia/dmU739T86cU/LKgmpqn6tMEJ)

That doesn't sound right to me. This bug was filed on a build with the month view & day view visual refresh changes included, so I don't think this is a bug where one visual refresh landed without the other.
build 20140519040204 uses Gaia https://github.com/mozilla-b2g/gaia/commits/101c500903a2477f9de1ea5ce523b9e0be4d45d0 (2014-05-16 17:40:15 -0300) Month View only landed at https://github.com/mozilla-b2g/gaia/commits/ed5d408dc1120b035ebce9a809499c30fbfb4582 a couple hours later (2014-05-16 19:52:09 -0300)

day and month views are very coupled, before the month view visual refresh they used basically the same markup and styling.

if you use a newer build this problem should not exist.
Ah I see - looks like the Monday build is an in between build. I'll mark qawanted to retest this on today's build to confirm this no longer exists.
Keywords: qawanted
This issue DOES NOT reproduce on today's build

Environmental Variables:
Device: Open_C 2.0
BuildID: 20140520053003
Gaia: d08eadf70936dec35498c309335e2caf0545e69b
Gecko: ee7140d6d111
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL
Keywords: qawanted
Status: NEW → RESOLVED
blocking-b2g: 2.0? → ---
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.