Chinese / Japanese interapplication clipboard only works one way (Outside -> Mozilla)

VERIFIED DUPLICATE of bug 79864

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 79864
16 years ago
16 years ago

People

(Reporter: Julian Hsiao, Assigned: nhottanscp)

Tracking

Trunk
mozilla1.0
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.4+) Gecko/20010921
BuildID:    2001092108

Chinese / Japanese text does not copy / paste correctly from Mozilla to another
application; within Mozilla it works fine.  In addition, copying text from
another application and paste it into Mozilla works fine also.

Reproducible: Always
Steps to Reproduce:
1. Go to a Chinese / Japanese website (localized Yahoo page, for example)
2. Copy text from the page, and paste it in another application (SimpleText, for
example).


Actual Results:  Question marks ("???") was pasted instead of the actual text.

Expected Results:  Chinese / Japanese text should be pasted.

Comment 1

16 years ago
Assiging Mac bugs to jbetak until nhotta comes back.
Assignee: yokoyama → jbetak

Comment 2

16 years ago
Which App? I know simple text does not work. but it seems most of the MacOS X
app which implement 'utxt' format work now.

Also, I believe this is related to the 'vers' resource. current, we will convert
Unicode to the system script which the 'vers' resource is. So... if the Japanese
version mark 'vers' as Japanese, then we should copy/paste Japanese to
SimpleText without problem. 

yxia, please make sure you tag the 'vers' langauge value correctly on Mac. That
will also impact Copy and Paste. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
? I don't get it. Does it mean if Ja people use our US build on their Ja system, 
they won't be able to copy/paste?

Comment 4

16 years ago
On Mac9.1-Ja OS & Japanese SimpleText editor:
I can copy/paste from N6.x browser to SimpText editor, and when I save the file 
and re-open it though SimpleText, the characters still display proerly.
(used 09-24 branch build)

So we can do copy/paste pages fine if user is using a localized OS even with our 
US build.

This problem is:
Copy/Paste Japanese or Chinese from US OS to US SimpleText editor, it shows "?" 
in the US SimpleText editor even by change the font to a Japanese font.
QA Contact: andreasb → ylong
(Reporter)

Comment 5

16 years ago
I'm sorry, I should have clarified my system configuration a bit more.  I'm
running the US version of MacOS 9.1 with Chinese / Japanese language kits
installed.  Since (Mr.? Ms. Mrs.?) Yuying Long says that it works under the
Japanese version of MacOS 9, I tried registering both Mozilla and SimpleText as
Japanese applications; it didn't help, however.

In fact, I don't even need to paste the text into another application to see
that it won't work: displaying the clipboard under Finder also shows "????"
instead of the intended text.  All other applications I tested that support
Chinese / Japanese will display the correct text in clipboard when copying.
this should probably go to nhotta, since it's Mac only - accepting for now.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 7

16 years ago
yes, let me take this.
Assignee: jbetak → nhotta
Status: ASSIGNED → NEW
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

16 years ago
Mozilla supported clipboard types for text are 'TEXT' and 'utxt'.
'TEXT' uses localized system setting, so needs Japanese localized system 
instead of language pack.
'utxt' is a unicode type mozilla supports it but not every app support 
this type.
'styl', this type maintains style information along with a plain text. On
Macintosh, a font id can be mapped to a script id, so application (e.g.
simpletext) can maintain script without depending on the localzied system charset.

I see more application support 'utxt' in MacOS X.
Bug 79864 is for 'styl' support, this is likely to be a dup of that bug.

Does copy to mozilla works? Which application are the data copied from?

 
(Reporter)

Comment 9

16 years ago
Hmm...I could have swear that pasting from SimpleText to Mozilla used to work,
but it doesn't when I just tried.  I tried using 2001080214 and 2001101208; does
anyone know how to get 2001092108?  It's probably that I forgot to test this
case initially and assumed it works, but I want to try it out again just to make
sure.
(Assignee)

Comment 10

16 years ago
link to the binary
http://ftp.mozilla.org/pub/mozilla/nightly/2001-09-21-08-trunk/
(Reporter)

Comment 11

16 years ago
Okay, I'm a moron...pasting Japanese text from SimpleText and ClarisWorks to
Mozilla doesn't work even it 2001092108, contrary to what I have claimed.
(Assignee)

Comment 12

16 years ago
Okay, then this is a dup of bug 79864, plain text ('TEXT') cannot hold multiple
scripts.

*** This bug has been marked as a duplicate of 79864 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 13

16 years ago
I'm marking this as dup. for now.  Please re-open if disagree.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.