Closed Bug 1012943 Opened 7 years ago Closed 7 years ago

flex row button children are not aligned in a row (on a <button>)

Categories

(Core :: Layout, defect)

28 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 984869

People

(Reporter: rusty.camden, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140314220517

Steps to reproduce:

http://jsfiddle.net/9VSVR/


Actual results:

http://jsfiddle.net/9VSVR/


Expected results:

the items should be next to each other
See bug 984869 comment 2.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Summary: flex row button children are not aligned in a row → flex row button children are not aligned in a row (on a <button>)
Duplicate of bug: 984869
(and as noted at the end of that comment, you may be able to achieve the layout you want if you put "display:flex" on a wrapper-div, just inside the <button>, as shown here: http://jsfiddle.net/9VSVR/1/ )
ah ok thanks
You need to log in before you can comment on or make changes to this bug.