Link only partly underlined when line wraps

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: mozilla, Assigned: attinasi)

Tracking

Trunk
mozilla1.2alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
See the page mentioned in the URL. The is a box with several links on the right
side. One of the links is wrapped to the next line, but the last word on the
first line 'Microsoft' is just underlined until the 'f'; the 't' is not underlined.

The box uses CSS, so it might be related to the other link underlined bugs, but
I did not find any like this.

I will attach a graphic how it looks like on my machine.
(Reporter)

Comment 1

17 years ago
Created attachment 50514 [details]
The second link is not underlined until the end of the word

Comment 2

17 years ago
Created attachment 50539 [details]
Result on my computer

Comment 3

17 years ago
It works on my computer (at least for the links).
But there is a bug when I load the page into a "big" mozilla and resize it
after: the right border of the window doesn't appear, even when the scrollbar is
on right (see the attachement).

I'm using Moz 0.9.4 with Linux 2.4.10 and XFree 4.1.0.1 (Debian Woody)
Kurt, what Mozilla build are you using?  What's your default font?  What X
server are you using?  Are you using a font server?

Comment 5

17 years ago
I thought the fields have been filled out by Mozilla, ok:

Mozilla 0.9.4; XFree 4.0 (SuSE 7.2); Microsoft fonts installed (there is a
script called 'fetchmsfonts' or so, that gets the free true type fonts from
Microsoft and installs them)

I can check if the bug appears on another machine without these fonts tomorrow.

Nevertheless, it appears with Win98; Mozilla 0.9.4 (Build ID: 2001091303) also
OS: Linux → Windows 98

Comment 6

17 years ago
Created attachment 50647 [details]
minimal testcase

Comment 7

17 years ago
Created attachment 50648 [details]
screenshot of testcase on win2k

Comment 8

17 years ago
I see this on Win2k with build 2001092103. If I resize the window slowly I can
reproduce every time.
seeing this on Linux too.  Over to layout.
Assignee: asa → attinasi
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
OS: Windows 98 → All
QA Contact: doronr → petersen
Hardware: PC → All
(Reporter)

Comment 10

17 years ago
Created attachment 50675 [details]
This happens on my machine (Linux, XF4.0) when I resize the window several time; this happens with the bugzilla window, too.
I can not reproduce using N6.2 on WINNT.
Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → mozilla1.2

Comment 12

17 years ago
*** Bug 138882 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.