Closed Bug 1013166 Opened 6 years ago Closed 6 years ago

Alert comes twice in MozActivity handlers

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P2, major)

ARM
Gonk (Firefox OS)

Tracking

(blocking-b2g:1.4+, b2g-v1.3 unaffected, b2g-v1.3T unaffected, b2g-v1.4 affected, b2g-v2.0 unaffected)

RESOLVED DUPLICATE of bug 994537
blocking-b2g 1.4+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- unaffected
b2g-v1.4 --- affected
b2g-v2.0 --- unaffected

People

(Reporter: poojas, Unassigned)

Details

Attachments

(1 file)

STR 1
Error notification is displayed twice, when any corrupted image file (empty .jpg file) is received through bluetooth. 

STR 2
Based on analysis we found that all alerts msg in handle MozActivity appears twice.
Easy way to reproduce this add an alert at [1]
Set picture as wallpaper and will get the same alert twice

[1] https://www.codeaurora.org/cgit/quic/lf/b2g/mozilla/gaia/tree/apps/wallpaper/js/share.js?h=mozilla/v1.4#n3
Can we check to see if we can reproduce this on 1.3?
Keywords: qawanted
I think this came with bug 951281.
Flags: needinfo?(crdlc)
Gregor,

Are we saying the fix for this issue is in bug 951281 OR this is a spillover from bug 951281?
Flags: needinfo?(anygregor)
I am a bit confused. That bug was landed 2014-02-13 so it is a bit strange that being detected this problem now, the root cause would be the bug 951281. BTW, I don't know if the alert is displayed twice when the user tries to set the image as a wallpaper or when the user tries to share it. Please could you provide some STR more specific? It would be very useful to understand properly the problem and also if you can attach some screenshot, it would be very appreciated. Thanks a lot for your support
Flags: needinfo?(crdlc)
(In reply to Cristian Rodriguez (:crdlc) from comment #4)

> 951281. BTW, I don't know if the alert is displayed twice when the user
> tries to set the image as a wallpaper or when the user tries to share it.

Exact STR is ,when you tries to receive corrupted image file (empty .jpg file) via BT then error alert msg appears twice.

After some analysis found that alert comes twice in every handleActivity functions and issue is not specific to BT.
So, suggested add alert at [1] and then "set wallpaper"  to reproduce this easily (to avoid BT activity)
[1] [1] https://www.codeaurora.org/cgit/quic/lf/b2g/mozilla/gaia/tree/apps/wallpaper/js/share.js?h=mozilla/v1.4#n3

> Please could you provide some STR more specific? It would be very useful to
> understand properly the problem and also if you can attach some screenshot,
> it would be very appreciated. Thanks a lot for your support

Video attached
According to comment 5 it does not seem what the bug is in download manager. It seems something related to Bluetooth and gallery app thought
blocking-b2g: 1.4? → 1.4+
Howie or Hema, could you verify whether or not this is related to BT or Gallery app?
Flags: needinfo?(hochang)
Flags: needinfo?(hkoka)
I can't recall, I think it was pdol that noticed that the error message displaying twice had two different headers in the video: Gallery and Homescreen.
Checked, this is not related to BT.
Flags: needinfo?(hochang)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #8)
> I can't recall, I think it was pdol that noticed that the error message
> displaying twice had two different headers in the video: Gallery and
> Homescreen.

Also the  first header is always with Gallery app but the sec one depends on the last open background app.(could be anything , camera, settings, music etc)
If no app opened in background then it comes from Homescreen
Well, according to this video [1], the download manager is not interacting in this scenario. So if it is failing, obviously the problem is in other part. I think so but I could be wrong, what do you think Francisco?

[1] https://www.codeaurora.org/cgit/quic/lf/b2g/mozilla/gaia/tree/apps/wallpaper/js/share.js?h=mozilla/v1.4#n3
Flags: needinfo?(francisco.jordano)
Flags: needinfo?(francisco.jordano) → needinfo?(arcturus)
Able to reproduce this on Buri with latest 1.4 but NOT on 2.0 and NOT on 1.3.
1.4 branch will be used to find the regression window.
QA Contact: pcheng
This bug occurs on the earliest 1.4 Aurora build (3/17), therefore the window was found in Central.

b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Buri MOZ
BuildID: 20140310204144
Gaia: b31771c0be6c4d7c67a8762be2f1b80237203b08
Gecko: 2d7ee32b5923
Version: 30.0a1
Firmware Version: v1.2-device.cfg

First Broken Environmental Variables:
Device: Buri MOZ
BuildID: 20140310211645
Gaia: 41d4cb48f5ff7f66ab5b6c1ac16203be06a62fb1
Gecko: 7218d9c3880a
Version: 30.0a1
Firmware Version: v1.2-device.cfg

Last Working Gaia / First Broken Gecko: Issue Does NOT reproduce
Gaia: b31771c0be6c4d7c67a8762be2f1b80237203b08
Gecko: 7218d9c3880a

Last Working Gecko / First Broken Gaia: Issue DOES reproduce
Gaia: 41d4cb48f5ff7f66ab5b6c1ac16203be06a62fb1
Gecko: 2d7ee32b5923

Gaia Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/b31771c0be6c4d7c67a8762be2f1b80237203b08...41d4cb48f5ff7f66ab5b6c1ac16203be06a62fb1
Caused by bug 977934.

Alive - Looks like it's another window mgmt regression. Can you take a look?
Blocks: 977934
Component: Gaia::System → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
This is dupe of bug 994537. We need to uplift the patch.
Flags: needinfo?(alive)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 994537
No longer blocks: 984663, 977934
Whiteboard: [CR 664258]
Flags: needinfo?(hkoka)
Flags: needinfo?(francisco)
Flags: needinfo?(anygregor)
You need to log in before you can comment on or make changes to this bug.