Closed Bug 1013348 Opened 6 years ago Closed 4 years ago

Generated eclipse project folder is clobbered after build

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1057986

People

(Reporter: botond, Unassigned)

References

(Blocks 1 open bug)

Details

I have been using BenWa's eclipse project generation (bug 973770) for B2G development.

Recently I pulled and rebuilt gecko, and my generated eclipse project was clobbered as a result. This is very annoying because it takes time to reconfigure the eclipse project.

Since the generated eclipse workspace is inside the object directory, I guess this is a natural consequence of a clobber build which deletes the entire object directory?

To resolve this, we should move the eclipse workspace out of the object directory. BenWa suggested allowing the user to specify the location of the workspace, with a sensible default.

Note that the workspace also cannot be inside the source directory, as the generated project links to the source directory as a virtual linked directory.
The ~/.mozbuild folder might be a good default location, as that contains other build meta-information.
... although that is shared across all srcdirs, so you'd have to ensure you separate different eclipse projects for different srcdirs somehow.
I was thinking of going with a sibling directory of the object directory, perhaps with the name being the object directory's name + an "-eclipse" suffix or something.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> ... although that is shared across all srcdirs, so you'd have to ensure you
> separate different eclipse projects for different srcdirs somehow.

We could md5 the real objdir path to solve that problem. Or go with a sibling. I think I prefer a sibling IMO.
This was actually fixed a long time ago in bug 1057986.
Assignee: botond → nobody
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1057986
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.