Status

defect
RESOLVED WORKSFORME
18 years ago
9 years ago

People

(Reporter: jenofontes, Assigned: edburns)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091311

I try to upload a web page with a java program in this ISP, it is make across a
Java program, well then the Java program don't start.
It is ok in Iexplorer (as always) and Netscape 4.74 too.



Reproducible: Always
Steps to Reproduce:
1.It is dificult, because the utilizacion of this Java Program is with users
registered, and password protected.
2. I can't revell my password for obvious rasons
3.

Actual Results:  the Java Program don't start

Expected Results:  an applet java program for upload (publication) web pages.
Well you could make us a test account if it is your site so we can see the
problem. Otherwise there isnt much we can do with this bug.

->OJI.
Assignee: ashuk → edburns
Component: Java APIs for DOM → OJI
QA Contact: avm → pmac

Comment 3

18 years ago
Reporter, please also copy what Java console might eventually mention via Tasks
-> Tools -> Java console.

Comment 4

18 years ago
Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

18 years ago
That show the Java Console.

Java (TM) Plug-in: Versión 1.3.1
Usar versión JRE 1.3.1 Java HotSpot(TM) Client VM
Directorio local del usuario = C:\Documents and Settings\Carlos

Configuración del delegado: Configuración del delegado del navegador



----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
q:   hide console
s:   dump system properties
t:   dump thread list
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------

java.lang.NoClassDefFoundError: com/ms/lang/RegKeyException

	at java.lang.Class.newInstance0(Native Method)

	at java.lang.Class.newInstance(Unknown Source)

	at sun.applet.AppletPanel.createApplet(Unknown Source)

	at sun.plugin.AppletViewer.createApplet(Unknown Source)

	at sun.applet.AppletPanel.runLoader(Unknown Source)

	at sun.applet.AppletPanel.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)
(Reporter)

Comment 6

18 years ago
bug persist in 2001112012 build, I posted java console messages.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 7

18 years ago
It is quite unclear what we can do about this without any way to reporduce the
problem. 

Please try to open java console before logging in, then set trace level to 5
and reproduce the problem. Please post here output from java console.

Could you please attach the source of web page with applet?

BTW, did you try another (newer) jre? Say, jre1.4beta3 from Sun?
(Reporter)

Comment 8

18 years ago
here I post the Java Console text, debug mode 5.
I will try to use other java versión, but, i remember that Netscape 4.7x run
these java program.
(Reporter)

Comment 9

18 years ago
a java program in this page have the same problem.
http://www.terra.es/juegos/
Build ID: 2001121403

Comment 10

17 years ago
jenofontes: I don't see any java on your page...
As for original report, we can't do anything w/o
source of page with applet.

Comment 11

17 years ago
Missing class RegKeyException seems to be part of 
Microsoft's Java SDK and it is used to read Windows registry
(therefore useless on Linux!).

Moreover i doubt this class is shipped with netscape 4.x.
 
Therefore i suspect the applet in question is windows-specific
 because it relies on usage of Microsoft java SDK. If 
 it work with Netscape 4.x for linux then this means 
 either applet or web-server check for browser version
 and behave differently. Then for some reason 
 mozilla is considered as IE (may be because all unknown 
 browsers are considered to be IE ...).

If above analysis is true then there is no way to fix this 
on mozilla side (actually this is not mozilla problem).
The possible workaround is to set custom 
User agent string in mozilla configuration file 
to convince Web-server that mozilla is not IE
(e.g. use netscape user agent string).
However, this can be tested only when bug 83376 will 
be fixed.

reporter: could you please clarify whether original applet 
 works with Netscape 4.x on Linux?

Updated

17 years ago
Depends on: 83376

Comment 12

17 years ago
No reply from reporter for more than a month. Marking worksforme...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
QA Contact: pmac → petersen

Updated

9 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.