Closed Bug 1013547 Opened 7 years ago Closed 4 years ago

Debugger doesn't show correct source when evalling script from sourcemapped script

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: hsteen, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

while debugging a site, I noticed that a big script was missing most of its contents when seen in the editor. Searching failed to find code I knew had come from the network.. Turns out a sourceMappingURL instruction (the actual URL was 404, if that matters) and code that triggers implicit or explicit eval() doesn't go well together: the eval'ed code is considered the real source code of that script.
OS: Android → All
Hardware: Other → All
I don't have enough information to tell if this bug is caused by source mapping, or if it is caused by the lack of Debugger.Source, and just happens to manifest when source mapping.

I'm grouping this under the source maps meta bug, mainly so Nick can take a look at it. Nick, feel free to remove it from the meta bug again if you feel it doesn't belong there.
Summary: debugger no longer shows actual source of script with sourceMappingURL set if it evaluates strings → Debugger doesn't show correct source when evalling script from sourcemapped script
=== website ===
http://hallvord.com/temp/moz/bug/1013547.htm

=== problem ===
You are right the source for .js file doesn't show up 30% of the time.  Its a serious problem, I was talking with others on stackoverflow chat about this (confirmed in release too).

=== cause ===
/browswer/devtools/debugger/
Priority: -- → P3
This seems to work fine with the new debugger.
I would have NI'd but the account is closed.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.