Closed Bug 1013550 Opened 8 years ago Closed 7 years ago

[B2G][Mobile] m.homedepot.com favicon not displayed in Top sites, Bookmark, and History

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.3 affected, b2g-v1.4 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3 --- affected
b2g-v1.4 --- affected

People

(Reporter: psiphantong, Unassigned)

References

()

Details

(Whiteboard: [flame-1.4-exploratory] [country-all])

Attachments

(1 file)

Attached image 2014-05-20-11-54-12.png
Description:
When user goes to the Home Depot main page, the graphic to the left of the address in Top sites, Bookmark, and History will not display


Repro Steps:
1. Go to http://m.homedepot.com/
2. Bookmark the page
3. Tap the address bar > Top sites > Bookmarks > History 


Actual:
Home Depot graphic to the left of the address in Top sites, Bookmark, and History will not display


Expected:
Home Depot graphic to the left of the address in Top sites, Bookmark, and History should display just like the Firefox browser 


The issue occurs on the following devices:

1.4F Environmental Variables:
Device: Flame 1.4F
BuildID: 20140519000201
Gaia: defd0650fb9d30c6515d50a89e72d8fb74ce7e62
Gecko: d95594048b36
Version: 30.0
Firmware Version: v10F-3

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140516000201
Gaia: 32fca83da31b9a0f9a5a88f96c913a25accdc14b
Gecko: a1e455367fa6
Version: 30.0
Firmware Version: v1.2-device.cfg

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140514024003
Gaia: 96e3fa769a436a2182e6d54088fb41386eb2b5b5
Gecko: 685cf1d0dedb
Version: 28.0
Firmware Version: v1.2-device.cfg
 

Repro frequency: 100%
See attached: screenshot
Duplicate of this bug: 1013535
Whiteboard: [openc-1.4-exploratory] → [flame-1.4-exploratory]
hmm Firefox for Android is adding an icon to the bookmarks indeed… BUT the link for the favicon is not in the markup. So I'm not sure where does it get the icon from? Is there an additional layer of heuristics that Firefox Android does?

On Firefox OS, there is no icon and that sounds natural given the markup.

Anyway that doesn't sound like a Web Compatibility bug.
Whiteboard: [flame-1.4-exploratory] → [flame-1.4-exploratory] [country-all]
This bug doesn't seem like a compat issue. If you bookmark the "cart" page of the mobile site, you have a favicon. The difference being that site is hosted at www. not m.

Comparing between the two servers:

mtaylor at omg-2 in ~/tmp/tmp.noindex
$ curl -I http://m.homedepot.com/favicon.ico
HTTP/1.1 200 OK
Server: nginx/1.5.0
Content-Length: 3638
X-dynaTrace: PT=13530;PA=334228137;RS=Production Live/20140807003013_0.session;SP=Production Live;PS=-1262753182
dynaTrace: PT=13530;PA=334228137;RS=Production Live/20140807003013_0.session;SP=Production Live;PS=-1262753182
Last-Modified: Fri, 31 Jan 2014 15:53:12 GMT
Accept-Ranges: bytes
ETag: W/"3638-1391183592000"
Accept-Ranges: bytes
X-Varnish: 1518738567
X-Varnish-Cache: MISS
Cache-Control: max-age=39679
Expires: Wed, 13 Aug 2014 02:13:45 GMT
Date: Tue, 12 Aug 2014 15:12:26 GMT
Connection: keep-alive

mtaylor at omg-2 in ~/tmp/tmp.noindex
$ curl -I http://www.homedepot.com/favicon.ico
HTTP/1.1 200 OK
Server: nginx
Content-Type: image/x-icon
Content-Length: 3638
Last-Modified: Thu, 08 Dec 2011 19:40:04 GMT
Accept-Ranges: bytes
Cache-Control: max-age=39621
Expires: Wed, 13 Aug 2014 02:12:50 GMT
Date: Tue, 12 Aug 2014 15:12:29 GMT
Connection: keep-alive
Set-Cookie: HD_DC=origin; path=/; domain=.com

"Content-Type: image/x-icon" may be important here, I don't know--I'm not familiar with the b2g source.

At any rate, Firefox for Android is able to handle both favicons, so Firefox OS should also be.
Component: Mobile → Gaia::Browser
Product: Tech Evangelism → Firefox OS
(possibly not the right component...)
Summary: [B2G][Mobile] The Home Depot graphic does not display in Top sites, Bookmark, and History in Firefox mobile → [B2G][Mobile] m.homedepot.com favicon not displayed in Top sites, Bookmark, and History
Seems to work for me in 2.2  It may be due to the change in browser being a system app?  Not sure.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.