Closed Bug 10137 Opened 22 years ago Closed 22 years ago

Click on Link toolbar button in editor results in a crash

Categories

(Core :: DOM: Editor, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: lchiang, Assigned: akkzilla)

Details

Click on Link toolbar button in editor results in a crash

Build:  Win32 1999071911 release build

1)  Start Apprunner
2)  Tasks | Editor
3)  Click on the Link toolbar button

Actual results:  Crash occurs.

Expected result:  Dialog for adding a link appears

Additional info:   Also reproducible in the HTML mail compose window.  I did a
search of Editor bugs and didn't see this bug reported; sorry, if it's a
duplicate.  Did not try other platforms; will let the QA contact try it out.

Here is the Talkback information:  Incident 11322692

   xpcom.dll + 0xd8ef (0x6097d8ef)
   xpcom.dll + 0x4ac0 (0x60974ac0)
   raptorhtmlpars.dll + 0x3151 (0x608e3151)
   raptorhtmlpars.dll + 0x1436a (0x608f436a)
   raptorhtmlpars.dll + 0x14cc7 (0x608f4cc7)
   raptorhtmlpars.dll + 0x15afe (0x608f5afe)
   raptorhtmlpars.dll + 0x150f5 (0x608f50f5)
   raptorhtmlpars.dll + 0x150c3 (0x608f50c3)
   raptorhtmlpars.dll + 0x13879 (0x608f3879)
   raptorhtmlpars.dll + 0x2e92 (0x608e2e92)
   raptorhtmlpars.dll + 0x2f1d (0x608e2f1d)
   raptorhtmlpars.dll + 0xc149 (0x608ec149)
   raptorhtmlpars.dll + 0xbe2a (0x608ebe2a)
   raptorhtmlpars.dll + 0xc089 (0x608ec089)
   raptorweb.dll + 0x29f2 (0x609429f2)
   netlib.dll + 0x2b0f (0x607a2b0f)
   netlib.dll + 0x2900 (0x607a2900)
   plds3.dll + 0x18ee (0x608a18ee)
   plds3.dll + 0x186a (0x608a186a)
   plds3.dll + 0x1b18 (0x608a1b18)
   USER32.dll + 0x1268 (0x77e71268)
   nsappshell.dll + 0x186f (0x6082186f)
   apprunner.exe + 0x233d (0x0040233d)
   KERNEL32.dll + 0x1ba3c (0x77f1ba3c)
Assignee: buster → akkana
assigned to akkana for initial analysis.  sujay, is there any particular
selection that causes this to crash?  Or are you just clicking on the button
before any selection is set in the window?
Lisa are you just clicking on the link button
before any selection is set in the window?
Adding Charley to the cc list, since he owns insert link (though if it's in the
parser library it may well be my problem), and Kathy in case she might have time
to look at this.  My tree is in flux right now (a half-written wide-ranging API
change) and it'll be a while before it's back to a state where I can test this,
but if someone could give me a real stack trace (i.e. with file names and line
numbers) I could look and see if it's something I'm doing.  I don't see this in
my build from Friday, though.
This is working on Friday's release build for me.  Pls mark this worksforme if
no one else is seeing this problem any longer.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → WORKSFORME
I still don't have a build I can use, but no one else seems to be seeing this,
so I'm going to mark it WFM.  Reopen it if you see it again.
Status: RESOLVED → VERIFIED
I also don't see it...marking verified in 7/26 build.
setting to an approximate milestone so it can be off of the no TFV list
Target Milestone: --- → M7
You need to log in before you can comment on or make changes to this bug.