Can't reimport mail to 0.9.4 for Mac OS 9.x from 0.9.4 for X

RESOLVED WORKSFORME

Status

MailNews Core
Backend
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: carl krall, Unassigned)

Tracking

Trunk
mozilla1.1alpha
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.2) Gecko/20010629
BuildID:    20010909?

Just got a copy of OS X a couple of weeks ago, and decided to try living with it
for a while. I first downloaded NC 6.1 and it imported the wrong mail somehow,
so I used Moz 0.9.2 in Mac OS 9.1 to import my mail from NC 4.78, then dragged
the Mail and Bookmarks files from the
~/Documents/Mozilla/Profiles/myprofile/randomnumbers file to the Mozilla file in
Users/Library/Mozilla,  etc in X and it worked! All my mail came over and was
visible in X, with some of the same problems in "The Mail that would not die" bug.

Now when I go backwards and try to drag the Mail folder from Fizzilla to the
Mozilla Profiles folder in Mac OS 9.2.1 (updated in the meantime) it only shows
the mail up to the day I switched to X. So Fizzilla must store messages
differently somehow, and I cannot retrieve them except to go back to X and
forward them to myself. I have also tried to use NC 4.78 to read the files, and
it cannot read past the 9th of Sept, which is when I switched.

My apologies if this is not a bug, but it seems like there would be lots of
folks trying X, then returning after their patience wears thin. Surely some
accomodation for migrating between OS's or having a common file that Mozilla
from both OS's can write to and read from.

I tried moving the Mail file several times and always had the same result, so
I'm assuming that there's a different mail cache file in OS X. Also, I left the
"Leave messages on Server" checked in Mozilla for X (jic...), but am missing
everything I Sent after the 9th when I open those files in Mozilla for OS 9.x.


Reproducible: Always
Steps to Reproduce:
1. Use Fizzilla for email client
2. Try to drag Mail folder from Mozilla Folder in X partition to Mozilla Folder
in 9.x partition
3. 

Actual Results:  Mail gathered by Fizzilla will not be readable in Mozilla for
Mac os 9.x

Expected Results:  Would find a display my mail from Fizzilla

Comment 1

17 years ago
not a mail database issue, a backend issue, probably. JF, is someone doing OS/X?
Feel free to reassign to someone who is doing OS/X. Also, QA, could someone try
this on OS/X? Thanks!
Status: UNCONFIRMED → NEW
Component: Mail Database → Mail Back End
Ever confirmed: true

Comment 2

17 years ago
-> JF.
Assignee: bienvenu → ducarroz
(Reporter)

Comment 3

17 years ago
Was downloading a nightly and decided to open the Inbox files on Moz Classic and
X with a text editor while I was waiting.

The X Inbox has only the old mail, Sept 9 and back. But the Classic Inbox has
the mail after that, so it might be that my dragging the mail folder redid the
file path? It would appear that Fizzilla is saving mail in and using the Mozilla
folder in Classic. I'm having problems getting Classic to be stable in X since I
went to 9.2.1, but I'm going to reboot into it and see if Moz for Classic is
reading Fizzilla's file. 

What's odd about this to me is that I have the two systems on seperate
partitions, so it should have copied the mail files. Is there a path indicator
of some sort inside the Mail folder? What I'm betting is that they're reading
each other's folders somehow, cross platform.

I'm going to experiment with dragging only one file over and see if it changes
anything.

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1
(Reporter)

Comment 4

17 years ago
Sorry to add yet another comment to this bug, but now I'm thoroughly lost. 

Originally dragged the Mozilla folder from OS9 Documents to OS X Library folder
to copy Bookmarks/Mail. Which it did, but apparently both Moz  and Fizz were
actually reading off of the folder on the OS9 partition, and that's why the
original bug was submitted, because I couldn't figure that out.

Now both Moz and Fizz are reading from some file somewhere just fine, and since
the Bookmarks are right up-to-date in the OS9 folder I think it must be there. 

BUT, that Mail folder, when dragged from OS 9 partition to another OS 9
partition (on laptop) is way out of date (Bookmarks were fine). Opening the
Inbox in a text editor revelas two oddities; 1) no new mail since 9/14, and 2)
mail that was supposedly deleted going back to the first of the year and beyond
is still there, making for a document of titanic size. 

Could someone please take a moment to explain to me where my current mail is?
When I open Moz and Fizz it is current, but I cannot move it or archive it or
even FIND it. This needs to be either fixed or explained tuit suite. Much though
I love (and tirelessly recommend) Mozilla, not being able to sync Mail folders
is going to kill my interest in it.

And surely it slows Moz down to have to work with those huge files of undeleted
mail. My apologies again if I ask for the impossible or have overlooked
something obvious, but I can only find two Mozilla files with Mail Bookmarks,
etc. on my computer, and the Inboxes are identically out-of date.
(Reporter)

Comment 5

17 years ago
I solved the last problem I reported. Both versions of Mozilla (X and OS9) were
working off of a Mozilla folder in my OS 9 Trash. I am quite sure that I did not
put it there.

So the Mozilla folder in my OS 9 /Applications/Documents WAS outdated. If I had
not thought to look through the OS 9 Trash folder I would have never found it.
The folder in the Trash was totally up-to-date. 

I have since tried using Mozilla on both OS's and they work from that folder
(placed back in the Documents folder on the OS 9 partition) and so far it has
not moved back to the Trash. since I am rarely in OS 9 anymore I am mystified as
to how that folder got there, but have noticed that there were a lot of "Rescued
Items From...) folders in the Trash as well, just like the ones NC 4.7x used to
generate continually.

Knowing how these things go, this probably won't happen to anyone else, so I'll
just go quietly back to the Twilight Zone, playing my Theramin and whistling a
tune with a red face...&^) I only post this in case it should happen to some
other poor soul who's actually depending on Mozilla. 
Product: MailNews → Core

Updated

10 years ago
Assignee: ducarroz → nobody
Status: ASSIGNED → NEW
QA Contact: esther → backend
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 6

10 years ago
not 100% certain, but comment 5 sounds like WFM.
=> WFM per reporter
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.