Reload of mynetscape page generated huge text script - not page

VERIFIED WORKSFORME

Status

()

Core
Networking: HTTP
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: rslewine, Assigned: neeti)

Tracking

Trunk
Other
BeOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:0.9.3+) Gecko/20010823
BuildID:    2001082321

Following is what I got when reloading My netscape main page.
function setupWin(url,serviceID,theWidth,theHeight){ if (isGuest=="1")
{signInURL();return false;} var wrapperGet="int"; if
(customizeIDs.indexOf(serviceID)!=-1){wrapper_winn=window.open(url+'/form.psp','wrapper_winn','width='+theWidth+',height='+theHeight+',scrollbars');
wrapper_winn.focus(); } else {
wrapper_winn=window.open('/shared/dhtmlwrapper.psp?service='+serviceID+'&url='+es(url).replace(/\./g,"%2E")+'/form.psp&get=int','wrapper_winn','width='+theWidth+',height='+theHeight+',scrollbars');
wrapper_winn.focus(); } return false; } function
wrapperWin(path,winWidth,winHeight){ if (winWidth==null||winWidth=="")
winWidth=430; if (winHeight==null||winHeight=="") winHeight=430;
wrapper_winn=window.open('/shared/loadurl.psp?path='+escape(path).replace(/\./g,'%2E'),'wrapper_winn','width='+winWidth+',height='+winHeight+',scrollbars=no'
); wrapper_winn.focus(); } function wrapperWin2(path,winWidth,winHeight){ if
(winWidth==null||winWidth=="") winWidth=430; if (winHeight==null||winHeight=="")
winHeight=430;
wrapper_winn=window.open('/shared/loadurl.psp?path='+escape(path).replace(/\./g,'%2E'),'wrapper_winn','width='+winWidth+',height='+winHeight+',scrollbars=yes'
); wrapper_winn.focus(); } function lookup2(f) { if (f.search.value!='') {
if(checkError(f.search.value,'Please enter a city, state, country, or zip
code.'))
wrapperWin2('/us/en_us_mynscp/services/weather/weatherresults.psp?search='+f.search.value,'860',
'860'); } else alert(weather_entercity); } function lookup3(f) { if
(f.search.value!='') { if(checkError(f.search.value,'Please enter a keyword.'))
wrapperWin2('/us/en_us_mynscp/services/news/news_search.psp?search='+f.search.value,'860',
'860'); } else alert('no keyword entered'); } function handleClicks() { var a=0;
} function moreSigns2(theVal,sb) { //alert("en_us_mynscp.js moreSigns2"); if
(sb==''||sb==null) { if (theVal!="") { theVal=theVal.toLowerCase(); if
(isEmbedded==1) { //if aol client browser if (theVal.indexOf("cancer")==-1) //if
not "cancer" top.location.href="aol://1722:"+theVal; else
top.location.href="aol://4344:892.hor_can.7823695.650207860"; } else { //is http
type URL newWin=window.open("","newWin"); if
(theVal.indexOf("aol://")==-1||theVal=="cancer") if (theVal=="capricorn")
newWin.location.href=("http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s=cp");
else
newWin.location.href="http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s="+theVal.substring(0,2);
else
newWin.location.href=("http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s=ca");
newWin.focus(); } } else alert(horoscopes_err); } else { if (theVal!="") {
theVal=theVal.toLowerCase(); if (isEmbedded==1) { //if aol client browser if
(theVal.indexOf("cancer")==-1) //if not "cancer"
top.location.href="aol://1722:"+theVal; else
top.location.href="aol://4344:892.hor_can.7823695.650207860"; } else { //is http
type URL newWin=window.open("","_content"); if
(theVal.indexOf("aol://")==-1||theVal=="cancer") if (theVal=="capricorn")
newWin.location.href=("http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s=cp");
else
newWin.location.href="http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s="+theVal.substring(0,2);
else
newWin.location.href=("http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s=ca");
newWin.focus(); } } else alert(horoscopes_err); } } function horoSigns2(theVal,
sb) { //alert("en_us_mynscp.js horoSigns2"); if ( (theVal!="") && (sb==''||
sb==null)) { newWin=window.open("","newWin"); newWin.location.href=(theVal); }
else if (theVal!="") { newWin=window.open(theVal,"_content"); } else
alert("core.js horoscopes_err"); } //Todays Features if
(parseFloat(navigator.appVersion) < 3) { document.write('');
location.HREF="http://home.netscape.com/computing/download/upgrade_index.html?cp=hom00xx";
} if (parseInt(navigator.appVersion)<4) { var platform="NON"; } else { var
platform=navigator.platform; } if (((parseInt(navigator.appVersion)==4) &&
(navigator.appName=="Netscape")) && (platform.indexOf('Mac')==-1)) {
document.classes.fsize2.all['fontSize']="12px";
document.classes.fsize3.all['fontSize']="14px";
document.classes.s1cA.all['fontSize']="11px";
document.classes.s1cB.all['fontSize']="11px";
document.classes.s1cC.all['fontSize']="11px";
document.classes.s1cE.all['fontSize']="11px";
document.classes.s2cA.all['fontSize']="13px";
document.classes.s2cB.all['fontSize']="13px";
document.classes.s2cD.all['fontSize']="13px";
document.classes.s2cE.all['fontSize']="13px";
document.classes.s2cF.all['fontSize']="13px";
document.classes.s3cB.all['fontSize']="15px"; } if
(navigator.appName=="Netscape" && platform.indexOf('Win')==0) { var srchsz=12;
var weatsz=5; var stoksz=5; } else if (((navigator.appName=="Netscape") &&
(platform.indexOf('Mac')==0)) && (parseInt(navigator.appVersion)<5)) { var
srchsz=22; var weatsz=8; var stoksz=8; } else if
(((navigator.appName=="Netscape") && (platform.indexOf('Mac')==0)) &&
(parseInt(navigator.appVersion)>4)) { var srchsz=14; var weatsz=5; var stoksz=5;
} else if (navigator.appName.indexOf("Microsoft")!=-1 &&
platform.indexOf('Mac')==0) { var srchsz=18; var weatsz=5; var stoksz=5; } else
if (navigator.appName=="Netscape" && platform.indexOf('Win')==-1 &&
platform.indexOf('Mac')!=0) { var srchsz=21; var weatsz=8; var stoksz=8; } else
{ var srchsz=24; var weatsz=9; var stoksz=9; } var searchform='

Reproducible: Didn't try

Actual Results:  function setupWin(url,serviceID,theWidth,theHeight){ if
(isGuest=="1") {signInURL();return false;} var wrapperGet="int"; if
(customizeIDs.indexOf(serviceID)!=-1){wrapper_winn=window.open(url+'/form.psp','wrapper_winn','width='+theWidth+',height='+theHeight+',scrollbars');
wrapper_winn.focus(); } else {
wrapper_winn=window.open('/shared/dhtmlwrapper.psp?service='+serviceID+'&url='+es(url).replace(/\./g,"%2E")+'/form.psp&get=int','wrapper_winn','width='+theWidth+',height='+theHeight+',scrollbars');
wrapper_winn.focus(); } return false; } function
wrapperWin(path,winWidth,winHeight){ if (winWidth==null||winWidth=="")
winWidth=430; if (winHeight==null||winHeight=="") winHeight=430;
wrapper_winn=window.open('/shared/loadurl.psp?path='+escape(path).replace(/\./g,'%2E'),'wrapper_winn','width='+winWidth+',height='+winHeight+',scrollbars=no'
); wrapper_winn.focus(); } function wrapperWin2(path,winWidth,winHeight){ if
(winWidth==null||winWidth=="") winWidth=430; if (winHeight==null||winHeight=="")
winHeight=430;
wrapper_winn=window.open('/shared/loadurl.psp?path='+escape(path).replace(/\./g,'%2E'),'wrapper_winn','width='+winWidth+',height='+winHeight+',scrollbars=yes'
); wrapper_winn.focus(); } function lookup2(f) { if (f.search.value!='') {
if(checkError(f.search.value,'Please enter a city, state, country, or zip
code.'))
wrapperWin2('/us/en_us_mynscp/services/weather/weatherresults.psp?search='+f.search.value,'860',
'860'); } else alert(weather_entercity); } function lookup3(f) { if
(f.search.value!='') { if(checkError(f.search.value,'Please enter a keyword.'))
wrapperWin2('/us/en_us_mynscp/services/news/news_search.psp?search='+f.search.value,'860',
'860'); } else alert('no keyword entered'); } function handleClicks() { var a=0;
} function moreSigns2(theVal,sb) { //alert("en_us_mynscp.js moreSigns2"); if
(sb==''||sb==null) { if (theVal!="") { theVal=theVal.toLowerCase(); if
(isEmbedded==1) { //if aol client browser if (theVal.indexOf("cancer")==-1) //if
not "cancer" top.location.href="aol://1722:"+theVal; else
top.location.href="aol://4344:892.hor_can.7823695.650207860"; } else { //is http
type URL newWin=window.open("","newWin"); if
(theVal.indexOf("aol://")==-1||theVal=="cancer") if (theVal=="capricorn")
newWin.location.href=("http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s=cp");
else
newWin.location.href="http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s="+theVal.substring(0,2);
else
newWin.location.href=("http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s=ca");
newWin.focus(); } } else alert(horoscopes_err); } else { if (theVal!="") {
theVal=theVal.toLowerCase(); if (isEmbedded==1) { //if aol client browser if
(theVal.indexOf("cancer")==-1) //if not "cancer"
top.location.href="aol://1722:"+theVal; else
top.location.href="aol://4344:892.hor_can.7823695.650207860"; } else { //is http
type URL newWin=window.open("","_content"); if
(theVal.indexOf("aol://")==-1||theVal=="cancer") if (theVal=="capricorn")
newWin.location.href=("http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s=cp");
else
newWin.location.href="http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s="+theVal.substring(0,2);
else
newWin.location.href=("http://info.netscape.com/fwd/myhoro/http://horoscopes.netscape.com/horoscopes/today/?cp=myhoro&s=ca");
newWin.focus(); } } else alert(horoscopes_err); } } function horoSigns2(theVal,
sb) { //alert("en_us_mynscp.js horoSigns2"); if ( (theVal!="") && (sb==''||
sb==null)) { newWin=window.open("","newWin"); newWin.location.href=(theVal); }
else if (theVal!="") { newWin=window.open(theVal,"_content"); } else
alert("core.js horoscopes_err"); } //Todays Features if
(parseFloat(navigator.appVersion) < 3) { document.write('');
location.HREF="http://home.netscape.com/computing/download/upgrade_index.html?cp=hom00xx";
} if (parseInt(navigator.appVersion)<4) { var platform="NON"; } else { var
platform=navigator.platform; } if (((parseInt(navigator.appVersion)==4) &&
(navigator.appName=="Netscape")) && (platform.indexOf('Mac')==-1)) {
document.classes.fsize2.all['fontSize']="12px";
document.classes.fsize3.all['fontSize']="14px";
document.classes.s1cA.all['fontSize']="11px";
document.classes.s1cB.all['fontSize']="11px";
document.classes.s1cC.all['fontSize']="11px";
document.classes.s1cE.all['fontSize']="11px";
document.classes.s2cA.all['fontSize']="13px";
document.classes.s2cB.all['fontSize']="13px";
document.classes.s2cD.all['fontSize']="13px";
document.classes.s2cE.all['fontSize']="13px";
document.classes.s2cF.all['fontSize']="13px";
document.classes.s3cB.all['fontSize']="15px"; } if
(navigator.appName=="Netscape" && platform.indexOf('Win')==0) { var srchsz=12;
var weatsz=5; var stoksz=5; } else if (((navigator.appName=="Netscape") &&
(platform.indexOf('Mac')==0)) && (parseInt(navigator.appVersion)<5)) { var
srchsz=22; var weatsz=8; var stoksz=8; } else if
(((navigator.appName=="Netscape") && (platform.indexOf('Mac')==0)) &&
(parseInt(navigator.appVersion)>4)) { var srchsz=14; var weatsz=5; var stoksz=5;
} else if (navigator.appName.indexOf("Microsoft")!=-1 &&
platform.indexOf('Mac')==0) { var srchsz=18; var weatsz=5; var stoksz=5; } else
if (navigator.appName=="Netscape" && platform.indexOf('Win')==-1 &&
platform.indexOf('Mac')!=0) { var srchsz=21; var weatsz=8; var stoksz=8; } else
{ var srchsz=24; var weatsz=9; var stoksz=9; } var searchform='

Expected Results:  Mynetscape should have reloaded
wfm with win2k build 20010924.. (maybe Beos only)

Reporter: 
Can you try it again with more recent build ?
Your build is too old (1 month old) !
from email :
I'd like to, but since I'm a user, not a developer, I need to wait for Dave at 
/http://www.geocities.com/arougthopher/ to make a new one. It only happened
once. Couldn't 
reproduce it. 

We sure could use a new one!-/
 Rich

--------------------------------------------------------------------

I think we don't support external builds. But you can download a BEOS version
directly from ftp.mozilla.org :
0.9.4:
ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla0.9.4/mozilla-i586-pc-beos-0.9.4.zip

and the latest nightly from :
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/ mozilla-i586-pc-beos.zip

And what do you mean with actual result ? Do you saw the HTML-Page as clear Text
in mozilla ?
Email:
Matti, 

Yes, what I sent you in the bug report was a copy/paste right from Mozilla. 
Are the ftp downloads you sent me binary, or must I compile first? 
Rich 
---------------------------------------------
This files are binarys.
And please comment directly in this bug(Use the "additional Comments" field and 
hit the "Commit" button.) 
If you email me, only I can read it and I'm now away for 1 week....

-> Networking:http based on the comments
Assignee: asa → neeti
Component: Browser-General → Networking: HTTP
QA Contact: doronr → tever

Comment 4

17 years ago
Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

16 years ago
Verified WFM.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
You need to log in before you can comment on or make changes to this bug.