makeinstall does not copy oji.lib

RESOLVED WONTFIX

Status

Core Graveyard
Java: OJI
RESOLVED WONTFIX
17 years ago
8 years ago

People

(Reporter: Jon Smirl, Assigned: Nidheesh Dubey)

Tracking

({topembed-})

Trunk
x86
Windows 98
topembed-
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
oji.lib is not getting copied to the dist/lib directory like it should as part 
of the build process. The dll is getting copied. This makes building in the 
mozilla\java directory fail.
(Reporter)

Updated

17 years ago
Blocks: 101408

Comment 1

17 years ago
Reassign to Joe as I'm leaving the role of OJI module owner.
Target Milestone: --- → mozilla0.9.5

Comment 2

17 years ago
Ressign to Joe Chou, as I am no longer working officially on OJI.
Assignee: edburns → joe.chou
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 3

17 years ago
Reporter, what mozilla you used (trunk, some branch)? Would you provide
something to reproduce the problem? Thanks.
(Reporter)

Comment 4

17 years ago
Trunk of Mozilla as day bug was filed.  This is just a simple problem in the 
makefile file, work around was to manually copy oji.lib.

Comment 5

17 years ago
Re-assign to nidheesh.
Assignee: joe.chou → nidheesh
Target Milestone: mozilla0.9.6 → mozilla0.9.9

Comment 6

17 years ago
nidheesh, do you think that you can fix this before 0.9.9??

Chris, do you think that you can help us here?

Updated

17 years ago
Blocks: 104172
I think the key to this is in line 441 of config/rules.mak :

# Build the component as a standalone DLL. Do _not_ install the import
# library, because it's a component; nobody should be linking against
# it!

So why is the mozilla/java (blackwood?) makefiles trying to link against a
component?  Also, according to the rules.mak, you can't build both java & oji
into the same app.  

(Reporter)

Comment 8

17 years ago
These makefiles reference oji.lib:

java\dom\src\makefile.win
java\pluggable-jvm\wf_moz6\public\makefile.win
java\pluggable-jvm\wf_moz6\src\makefile.win
java\plugins\src\makefile.win

I don't know why they need oji.lib, I just tried to build the java directory 
and got a bunch of errors and then proceeded to fix them.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: mozilla1.0

Updated

17 years ago
Keywords: topembed

Comment 9

16 years ago
topembed-
not clear from summary and description
if this is important for embedding, escalate by removing -

- triage team (chofmann, cathleen, marcia)
Keywords: topembed → topembed-

Updated

16 years ago
QA Contact: pmac → petersen
Keywords: mozilla1.0
Target Milestone: mozilla0.9.9 → ---

Comment 10

15 years ago
The nmake build system has been removed.  Marking this wontfix. (We need a
NO_LONGER_RELEVANT bug state.)
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.