Closed Bug 1014161 Opened 6 years ago Closed 6 years ago

input type=file is broken?

Categories

(Firefox for Android :: General, defect)

32 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox29 --- unaffected
firefox30 --- unaffected
firefox31 --- unaffected
firefox32 --- verified
fennec 30+ ---

People

(Reporter: krudnitski, Assigned: wesj)

References

()

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

I can't seem to upload a picture to a Facebook status or to Ottawa.kijiji.ca or usedottawa.ca. it just hangs and doesn't upload, but I can still navigate and input text into fields. 

I used to be able to, but noticed this maybe a week or so ago? Works on beta, but nightly is broken.
Does the filename appear in the textbox? If not, what app are you getting the file from? i.e. Gallery/Documents/etc?
Nothing happens. Nothing at all. No'loading' action from the browser, nothing. I tried using the gallery, documents and photos for uploading to usedottawa and kijiji with no success. Tried the gallery for Facebook and nothing happened, just a placeholder in that case
Wes - Is this related to other uploading/attaching bugs?
tracking-fennec: ? → 30+
Karen, can you try on nightly? bug 1001851 just landed on beta
Flags: needinfo?(krudnitski)
On Nightly on a basic file upload test-site [1], I get the ChooserActivity on tap of 'browse', I select 'Documents' (Android 4.4.2), select a file but do not see it selected in the input. I suspect this is the problem that Karen is seeing on Facebook (haven't tested Facebook or Aurora yet). This works on Firefox 30/29.

On file selection I see in logcat (D/GeckoBrowserApp)

onActivityResult: 7, -1, Intent { dat=content:com.android.providers.downloads.documents/document/1573 flg=0x1 } 

but no errors in console

[1] http://encodable.com/uploaddemo/
Summary: Uploading pictures is broken → input type=file is broken?
Flags: needinfo?(krudnitski)
Made a mistake, I see the same thing on Firefox 30 on that test-page
What he said.
(In reply to Mark Finkle (:mfinkle) from comment #3)
> Wes - Is this related to other uploading/attaching bugs?

Probably. "Documents" is expected to be broken on 30 (Google changed how things work in KitKat). Use some other app if you're testing there to not confuse this.
Attached patch PatchSplinter Review
I thought I was crazy at first and my old patches were somehow busted, but rnewman broke this with the locale switcher :)

This just adds a super.onActivityResult call in this function, but I also made the indentation consistent with our other switch statements (well... I thought I did. I now see that we have a couple different styles scattered around...)
Attachment #8429401 - Flags: review?(rnewman)
Attachment #8429401 - Flags: review?(rnewman) → review+
https://hg.mozilla.org/mozilla-central/rev/643749739862
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Too late for 30
Status: RESOLVED → VERIFIED
Beta (file upload behaviour when picking a file through KitKat's Documents) is fixed via bug 1001851. I don't know if this is still needed on mozilla-beta.
As is Aurora WFM.
This onActivityResult block was only added by Bug 917480 in 32, so this patch isn't needed on Aurora or Beta.

Marking as unaffected per Comment 13 and Comment 14. The KK documents issue was a separate bug altogether.
You need to log in before you can comment on or make changes to this bug.