Closed Bug 1014181 Opened 5 years ago Closed 5 years ago

Crash when long pressing text selection Actionbar icons on Gingerbread

Categories

(Firefox for Android :: General, defect, critical)

x86_64
Linux
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Firefox 33
Tracking Status
firefox32 --- verified
firefox33 --- verified
fennec 32+ ---

People

(Reporter: wesj, Assigned: wesj)

References

Details

(Keywords: crash)

Attachments

(1 file)

I shoulda caught this in review. Presumably because our menu implementations are very different on GB.

GeckoAppShell: java.lang.NoSuchMethodError: android.view.MenuItem.getActionView
GeckoAppShell: 	at org.mozilla.gecko.ActionModeCompat.onMenuItemLongClick(ActionModeCompat.java:102)
GeckoAppShell: 	at org.mozilla.gecko.widget.GeckoPopupMenu.onMenuItemLongClick(GeckoPopupMenu.java:161)
GeckoAppShell: 	at org.mozilla.gecko.menu.GeckoMenu.access$100(GeckoMenu.java:35)
GeckoAppShell: 	at org.mozilla.gecko.menu.GeckoMenu$2.onLongClick(GeckoMenu.java:230)
GeckoAppShell: 	at android.view.View.performLongClick(View.java:2503)
GeckoAppShell: 	at android.view.View$CheckForLongPress.run(View.java:9065)
GeckoAppShell: 	at android.os.Handler.handleCallback(Handler.java:587)
GeckoAppShell: 	at android.os.Handler.dispatchMessage(Handler.java:92)
GeckoAppShell: 	at android.os.Looper.loop(Looper.java:130)
GeckoAppShell: 	at android.app.ActivityThread.main(ActivityThread.java:3806)
GeckoAppShell: 	at java.lang.reflect.Method.invokeNative(Native Method)
GeckoAppShell: 	at java.lang.reflect.Method.invoke(Method.java:507)
GeckoAppShell: 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:839)
GeckoAppShell: 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:597)
GeckoAppShell: 	at dalvik.system.NativeStart.main(Native Method)
Severity: normal → critical
Keywords: crash
Attached patch PatchSplinter Review
getActionView wasn't added until Honeycomb, but we implemented our own version for GeckoMenuItem.
Attachment #8426555 - Flags: review?(bnicholson)
Comment on attachment 8426555 [details] [diff] [review]
Patch

Review of attachment 8426555 [details] [diff] [review]:
-----------------------------------------------------------------

Have you verified that this works? I've never tried calling an overridden method from a higher API -- I guess it's OK as long as you don't call super?
Attachment #8426555 - Flags: review?(bnicholson) → review+
Comment on attachment 8426555 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 943908
User impact if declined: crash on 2.3 devices
Testing completed (on m-c, etc.): landed today
Risk to taking this patch (and alternatives if risky): pretty low risk cast. We control these menus entirely, so we know they're GeckoMenuItems
String or IDL/UUID changes made by this patch: none
Attachment #8426555 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1029255
https://hg.mozilla.org/mozilla-central/rev/a05f8bb2e876
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
tracking-fennec: --- → 32+
Attachment #8426555 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed in builds:
Firefox for Android 32.0a2 (2014-07-03)
Firefox for Android 33.0a1 (2014-07-03)

Device:
Samsung Galaxy R (Android 2.3.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.