Closed Bug 1014210 Opened 7 years ago Closed 7 years ago

updater hotfix: collect data about update success rate and send anonymized server logs

Categories

(Firefox :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: benjamin, Unassigned)

References

Details

After the addon hotfix has successfully updated the user, we want to know several extra pieces of data:

* Record in FHR that this user was updated by the hotfix, and what version of Firefox they were using prior to update
* Include the the log and other details of the prior failed updates in the FHR payload.

I expect that technically how this will work is we'll stick some log data into the profile before we update, and then after we update the client will check and slurp those files and send them around. If you've got better ideas, excellent.

rstrong, can you provide details about where we should look for the failed update log and whether there are any other pieces of information we should be collecting, e.g. the value of the update.url pref?

I'm going to file a separate bug about anonymizing the update log.
Flags: needinfo?(robert.strong.bugs)
Bug 946894 has some of the details regarding the logs.

The root dir for the files should be under "UpdRootD" as the first choice and "XCurProcD" if not under "UpdRootD".

The structure is
<rootdir>/active-update.xml
<rootdir>/updates.xml
<rootdir>/updates/backup-update.log
<rootdir>/updates/last-update.log

It would also be good to know if there are files under
<rootdir>/updates/0/
Flags: needinfo?(robert.strong.bugs)
Blocks: 1014524
Benjamin and I talked about this. My opinion is that incorporating the data into FHR feels like a one-off and is added complexity that we would prefer to avoid. We would like to request a one-off server collection point for this data. Perhaps we can deploy a new Telemetry server in AWS, leverage an existing Telemetry server, deploy a new Bagheera namespace, etc. The exact solution shouldn't matter too much - we just want something that receives JSON documents. We could probably deploy our own server in AWS if pressed.

Needinfo benjamin to follow up with the server-side deployment.
Flags: needinfo?(benjamin)
Depends on: 1019788
Flags: needinfo?(benjamin)
Assignee: nobody → gps
It isn't clear to me that this bug is tracking anything currently.

The current implementation of the hotfix uploads a sanitized version of the installer.log to a one-off Telemetry server and it is my understanding (by way of granted review from bsmedberg) that this is sufficient.

If we need to collect more, please clarify what. Else, please mark this as a duplicate of bug 1014194 or WONTFIX.
Assignee: gps → nobody
Flags: needinfo?(benjamin)
This was broken out specifically for the data collection. You implemented it all at once, so I think we can just mark it FIXED.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(benjamin)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.