Closed Bug 1014215 Opened 7 years ago Closed 7 years ago

Updater hotfix: anonymize the collected update log

Categories

(Firefox :: General, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1014194

People

(Reporter: benjamin, Assigned: gps)

References

Details

We want to collect updater logs for users who were failing to update properly. According to rstrong, these logs can contain the username in various path components, but are unlikely to contain any other personal data. We need to strip out the username path components before submission.

rstrong do you have any suggested techniques?

This should probably take the form of a .jsm API:

function sanitizeUpdateLog(inpath, outpath) {
  ...
}

This code needs to work in Firefox 10+ and so it cannot use OS.File or any modern async goodies.
Flags: needinfo?(robert.strong.bugs)
Flags: firefox-backlog+
See bug 1014210 comment #1 for more details

As for suggested techniques I'd go with checking the lines before UPDATE TYPE partial / UPDATE TYPE complete that don't start with DESTINATION DIRECTORY or calling QuitProgressUI.
Flags: needinfo?(robert.strong.bugs)
Assignee: nobody → gps
This is implemented in bug 1014194.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1014194
Flags: firefox-backlog+ → firefox-backlog-
Whiteboard: p=5
You need to log in before you can comment on or make changes to this bug.