Closed Bug 1014381 Opened 8 years ago Closed 8 years ago

[Tarako] Sometimes tarako crash automatically and back to menu interface while using Youtube app

Categories

(Firefox OS Graveyard :: Performance, defect)

ARM
Linux
defect
Not set
major

Tracking

(b2g-v1.3T affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: james.zhang, Unassigned)

References

Details

(Whiteboard: [sprd298584 ] [partner-blocker] LMK)

Attachments

(1 file)

1.Sometimes tarako crash automatically and back to menu interface while using Youtube app.
2.tarako fail to have smooth scroll on videos list while using Youtube app.
blocking-b2g: --- → 1.3T?
Whiteboard: [sprd298584 ]
Wait our QA catch new log.
James, could you please attach a logcat and dmesg log for the 1st issue.
Blocks: b2g-youtube
Flags: needinfo?(james.zhang)
Attached file Youtube_slog.rar
Flags: needinfo?(james.zhang)
Ying, please track this issue.
Flags: needinfo?(ying.xu)
I only found YouTube was killed by LMK at background, the timestamp is 20:40:52 and 20:43:34. In these two cases, YouTube is back to background due to Communications is running at foreground, so YouTube was killed by LMK is reasonable. Moreover, I also didn't find any crash in main.log

3460:05-22 20:40:52.657 <4>0[  377.313847] lowmem_shrink send sigkill to 579 (YouTube), adj 10, size 8480
...
05-22 20:40:52.676 <6>0[  377.320385] [  579] 10579   579    22408     5307   0      10           667 YouTube
05-22 20:40:52.676 <6>0[  377.320450] [  615] 10615   615    16395     4111   0       2           134 Communications
...
3720:05-22 20:41:24.015 <4>0[  408.677491] lowmem_shrink send sigkill to 615 (Communications), adj 10, size 5493
...
05-22 20:41:24.040 <6>0[  408.682704] [  615] 10615   615    15660     3018   0      10           667 Communications
05-22 20:41:24.040 <6>0[  408.682773] [  791] 10791   791    19862     7949   0       2           134 YouTube
...
4233:05-22 20:42:56.511 <4>0[  501.171767] lowmem_shrink send sigkill to 372 (Homescreen), adj 8, size 5665
...
05-22 20:42:56.526 <6>0[  501.178979] [  791] 10791   791    22528     5767   0       2           134 YouTube
05-22 20:42:56.526 <6>0[  501.179043] [  818] 10818   818    14627     3687   0       1            67 Communications
...
4503:05-22 20:43:34.141 <4>0[  538.803814] lowmem_shrink send sigkill to 791 (YouTube), adj 10, size 7952
...
05-22 20:43:34.142 <6>0[  538.808976] [  791] 10791   791    20911     5710   0      10           667 YouTube
05-22 20:43:34.142 <6>0[  538.809041] [  818] 10818   818    16395     4807   0       6           400 Communications
...

Hi James, we might need your help to confirm whether you recieved/make any call when you are doing tests. From the log, we can see Communication app starts. Could you help to provide the video to let us know what happened that you think YouTube app is crash?
Flags: needinfo?(james.zhang)
Let's check it with our Indian QA.
Flags: needinfo?(james.zhang)
The reason that Communication app starts and jumps to foreground is DUT received USSD.

05-22 20:40:39.408    85    85 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}
05-22 20:40:39.408    85    85 I Gecko   : -*- RadioInterface[0]: USSDReceived {"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}
05-22 20:40:39.408    85    85 I Gecko   : -*- RadioInterface[0]: handleUSSDReceived {"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}
05-22 20:40:39.698    85    85 I Gecko   : -*- RILContentHelper: Received message 'RIL:USSDReceived': {"clientId":0,"data":{"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}}
05-22 20:40:40.108    85    85 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}
05-22 20:40:40.108    85    85 I Gecko   : -*- RadioInterface[0]: USSDReceived {"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}
05-22 20:40:40.108    85    85 I Gecko   : -*- RadioInterface[0]: handleUSSDReceived {"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}
05-22 20:40:40.138    85    85 I Gecko   : -*- RILContentHelper: Received message 'RIL:USSDReceived': {"clientId":0,"data":{"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}}
05-22 20:42:53.798    85    85 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}
05-22 20:42:53.798    85    85 I Gecko   : -*- RadioInterface[0]: USSDReceived {"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}
05-22 20:42:53.798    85    85 I Gecko   : -*- RadioInterface[0]: handleUSSDReceived {"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}
05-22 20:42:55.028    85    85 I Gecko   : -*- RILContentHelper: Received message 'RIL:USSDReceived': {"clientId":0,"data":{"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}}
05-22 20:42:55.028    85    85 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}
05-22 20:42:55.028    85    85 I Gecko   : -*- RadioInterface[0]: USSDReceived {"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}
05-22 20:42:55.028    85    85 I Gecko   : -*- RadioInterface[0]: handleUSSDReceived {"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}
05-22 20:42:55.068    85    85 I Gecko   : -*- RILContentHelper: Received message 'RIL:USSDReceived': {"clientId":0,"data":{"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}}
05-22 20:46:16.928    85    85 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}
05-22 20:46:16.928    85    85 I Gecko   : -*- RadioInterface[0]: USSDReceived {"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}
05-22 20:46:16.928    85    85 I Gecko   : -*- RadioInterface[0]: handleUSSDReceived {"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}
05-22 20:46:17.358    85    85 I Gecko   : -*- RILContentHelper: Received message 'RIL:USSDReceived': {"clientId":0,"data":{"rilMessageType":"USSDReceived","message":"LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.\nKaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ","sessionEnded":true,"rilMessageClientId":0}}
05-22 20:46:17.628    85    85 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}
05-22 20:46:17.628    85    85 I Gecko   : -*- RadioInterface[0]: USSDReceived {"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}
05-22 20:46:17.628    85    85 I Gecko   : -*- RadioInterface[0]: handleUSSDReceived {"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}
05-22 20:46:17.668    85    85 I Gecko   : -*- RILContentHelper: Received message 'RIL:USSDReceived': {"clientId":0,"data":{"rilMessageType":"USSDReceived","sessionEnded":true,"rilMessageClientId":0}}
So the story is probably like this:
User watches youtube with data network, and the network operator sends balance report through USSD which brought comms app up to foreground. Since comms app have higher priority than youtube app and device is under memory pressure, so youtube app is killed by LMK.
There is no CS call alive.
Youtube was killed due to LMK.


05-22 20:40:39.398    96   219 D RILC    : [UNSL]< UNSOL_ON_USSD {0,LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.
05-22 20:40:39.398    96   219 D RILC    : Kaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ,15}
05-22 20:40:39.408    85   317 I Gecko   : RIL Worker: [0] On USSD. Type Code: 0 Message: LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.
05-22 20:40:39.408    85   317 I Gecko   : Kaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316
...
05-22 20:40:52.878    85    85 E OomLogger: [Kill]: lowmem_shrink send sigkill to 579 (YouTube), adj 10, size 8480
...
05-22 20:42:53.778    96   219 D RILC    : [UNSL]< UNSOL_ON_USSD {0,LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.
05-22 20:42:53.778    96   219 D RILC    : Kaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ,15}
05-22 20:42:53.798    85   317 I Gecko   : RIL Worker: [0] On USSD. Type Code: 0 Message: LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.
05-22 20:42:53.798    85   317 I Gecko   : Kaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316
...
05-22 20:43:34.998    85    85 E OomLogger: [Kill]: lowmem_shrink send sigkill to 791 (YouTube), adj 10, size 7952
...
05-22 20:46:16.918    96   219 D RILC    : [UNSL]< UNSOL_ON_USSD {0,LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.
05-22 20:46:16.918    96   219 D RILC    : Kaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316 ,15}
05-22 20:46:16.928    85   317 I Gecko   : RIL Worker: [0] On USSD. Type Code: 0 Message: LastCall Charge Rs. 0.0 , Call Duration 00:00:00 .Current balance Rs. 330.01.
05-22 20:46:16.928    85   317 I Gecko   : Kaise dikhen Khoobsurat? Jaane Ayurveda Guru se, Call 5351316
Whiteboard: [sprd298584 ] → [sprd298584 ] [partner-blocker]
Whiteboard: [sprd298584 ] [partner-blocker] → [sprd298584 ] [partner-blocker] LMK
Hi Marvin, let's close the bug as WFM if partner cannot reproduce it further. thanks
Flags: needinfo?(mkhoo)
(In reply to Joe Cheng [:jcheng] from comment #10)
> Hi Marvin, let's close the bug as WFM if partner cannot reproduce it
> further. thanks

05-22 20:40:52.878    85    85 E OomLogger: [Kill]: lowmem_shrink send sigkill to 579 (YouTube), adj 10, size 8480

youtube was killed when at background.

It's OK for you to mark this bug as WFM
Flags: needinfo?(ying.xu)
the following STR is non repro now, thus, please close.
1.Sometimes tarako crash automatically and back to menu interface while using Youtube app.
2.tarako fail to have smooth scroll on videos list while using Youtube app. 

however,we should track https://bugzilla.mozilla.org/show_bug.cgi?id=1016885 
it's related to device receives USSD and YouTube being killed in background.
Flags: needinfo?(mkhoo)
per comment #1 WFM and clearing the nom.
Status: NEW → RESOLVED
blocking-b2g: 1.3T? → ---
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.