Closed Bug 1014417 Opened 6 years ago Closed 5 years ago

Support Contacts are not configured correctly for customization

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

Other
Other
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S3 (6june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: rafael.marquez, Assigned: eragonj)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(2 files)

support_contacts_movistar.json file:
{
  "onlinesupport": {
    "title": "Mozilla Support",
    "href": "http://test.mozilla.org/support"
  },
  "callsupport1": {
    "title": "Call Support (Primary)",
    "href": "tel:14155550001"
  },
  "callsupport2": {
    "title": "Call Support (Secondary)",
    "href": "tel:14155550002"
  }
}

****Steps
1. Installing a 2.0 build on device
2. Clone the tests repository for sigle variant: https://github.com/telefonicaid/firefoxos-gaia-testsbuild.git
3. Configuring the file variant.json and support_contacts_movistar.json
4. Clone Gaia repository and select the master branch.
5. Executing the command "GAIA_DISTRIBUTION_DIR="URL"/firefoxos-gaia-testsbuild  PRODUCTION=1 make reset-gaia" to install gaia with single variant in the device
6.Complete FTE  with a SIM card with a mnc/mcc configured in the variant.json
7. Open Settings apps
8. Tap on Help 


*Expected Result
onlinesupport, callsupport1 and callsupport2 are displayed in Settings/Helps

*Actual Result
callsupport2 is not displayed in Settings/Helps only onlinesuppor and callsupport1 are displayed
blocking-b2g: --- → 2.0?
Whiteboard: [systemsfe]
blocking-b2g: 2.0? → 2.0+
Hi Albert, could you help on this issue?
Flags: needinfo?(acperez)
Hi, yesterday I talked offline with Carmen and we suspect it isn't a problem of single variant build process, so she is going to have a look to this. However, if I finish bug 1009633 before she can have a look, I'll take this one.
Flags: needinfo?(acperez)
I'm investigating it.
Assignee: nobody → yurenju.mozilla
this is not an issue for customization per sim card because I can reproduce it with |GAIA_DISTRIBUTION_DIR=customization/ make reset-gaia|, change title.
Summary: [Single Variant] Support Contacts are not configured correctly for our mnc/mcc → Support Contacts are not configured correctly for customization
it should be an issue of settings app because support.json is copied into settings/resources/ if using |GAIA_DISTRIBUTION_DIR=customization make|.
Assignee: yurenju.mozilla → nobody
Component: Gaia::Build → Gaia::Settings
EJ, can you take a look to this issue? thanks :D
Flags: needinfo?(ejchen)
ok took it !
Assignee: nobody → ejchen
Flags: needinfo?(ejchen)
Attached file patch on master
Arthur,

I noticed this is a CSS flaw when we are doing 2.0 refactor plan.

Please give it a check ! Thanks :)
Attachment #8430579 - Flags: review?(arthur.chen)
Keywords: regression
Comment on attachment 8430579 [details] [review]
patch on master

Thanks for catching it, r=me.
Attachment #8430579 - Flags: review?(arthur.chen) → review+
Thanks all, landed on Gaia/master: a7ce376a5ffb9fd24d9c2f1b7899314495aa9baf
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Verified in master(2.0) branch
Status: RESOLVED → VERIFIED
Target Milestone: --- → 2.0 S3 (6june)
You need to log in before you can comment on or make changes to this bug.