Closed Bug 1014461 Opened 7 years ago Closed 7 years ago

Flat list of methods in the profiler

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

32 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 879008

People

(Reporter: p01, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140521030200

Steps to reproduce:

Working on PDF.js, or any similar big application, I want to optimize this puppy and do a console.profile('page '+pageView.id); /* call the renderTask that will take several seconds */ console.profileEnd();

Or simply open http://mozilla.github.io/pdf.js/web/viewer.html and profile the rendering of a couple of pages.


Actual results:

The profile is sorted chronologically and only shows a tree view of the calls.


Expected results:

There should be an option to see a flat list of ALL the methods, and sort them by:
* (aggregated) running time
* file
* parent method in the call stack
* ....
* first call
* last call

This would help a great deal to profile any application
Component: Untriaged → Developer Tools: Profiler
It is not sorted chronologically, it is sorted by what call stacks were sampled most often. Note that sampling profilers can't ever know exact running time by nature.

Bug 879008 will allow inverting the call stack and hopefully also present the data in a more intuitive way so that we don't confuse users as much.

I don't think there is anything actionable here that doesn't already exist in bug 879008 or isn't just a misunderstanding caused by our less-than-inuitive existing UI.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 879008
Thanks for the clarifications.

I didn't see a feature list or design document in the bug 879008

The key part in this bug report is the "Expected result"; this is a specific/actionable feature request for the new profiler.
Yeah they are kind of hidden via the bug's dependencies and discussions that tends to happen on irc.

If you have specific concerns, feel free to express them in that bug.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.