Shift-clicking to create selections does not work properly

RESOLVED FIXED in Future

Status

()

Core
Selection
RESOLVED FIXED
17 years ago
15 years ago

People

(Reporter: TucsonTester2, Assigned: Brade)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE+)

(Reporter)

Description

17 years ago
Build ID: 20010924

In Composer if you use shift-click to highlight a mixture of text and objects it
will not work properly.

Reproducibility: Everytime

Steps to Reproduce:
1.Open composer
2.Type a few lines of text
3.Insert a Horizontal Rule
4.Highlight the H.line
5.Shift+Click the top left part of the editable area

Actual Results:
The horizontal line will loose the highlighting, but the text will highlight.

Expected Results:
I would expect that the horizontal rule would stay highlighted and that the text
would just be added to the selection.
(Reporter)

Comment 1

17 years ago
There is also another problem that is related to using shift+click to highlight.
   If you have a horizontal rule at the begining of a composer page and text
below and use the shift-click to highlight, then the horizontal rule will not
highlight.

Reproducibility: Everytime

Steps to Reproduce:
1.Open composer
2.Insert an H.Line using the H.Line button on the toolbar
3.Type in a few lines of text
4.With the cursor to the very bottom right of the text, shift-click the
Horizontal Rule.

Actual Results:
The text will highlight but the horizontal rule will not. The only ways to get
around this are to shift-click the h.line a second time or to click to the left
of the h.line.

Expected Results:
I would expect that shift clicking on the horizontal rule would highlight the
text and the h.line.

Additional Info:
I forgot to add into the first report that the object could also be an image,
not just a horizontal rule.  This does not happen with tables because they are
selected differently and won't allow you to shift-click them.
(Assignee)

Comment 2

17 years ago
-->Selection
Assignee: syd → mjudge
Component: Editor: Composer → Selection
QA Contact: sujay → tpreston

Comment 3

17 years ago
Confirmed on Win 2k using build 2001110703.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
first testcase WFM.
second testcase reproducible, but is able to be worked around by shift clicking 
to the left of the h-rule (then it will be selected).

marking EDITORBASE and future.
Status: NEW → ASSIGNED
Whiteboard: EDITORBASE
Target Milestone: --- → Future

Comment 5

17 years ago
workaround is to select all of the content at the same time. EDITORBASE-
Whiteboard: EDITORBASE → EDITORBASE-

Updated

16 years ago
QA Contact: tpreston → beppe
Whiteboard: EDITORBASE- → EDITORBASE+

Comment 6

16 years ago
Just did a quick test on this one. If I follow the initial steps:
1. new window
2. enter few lines of text
3. insert HR
4. select HR and then shift+click upper-left of window

I can repro this easily. It seems that when I select the HR by just clicking on
it, the caret (although not visible) is really to the left of the HR element. So
when I shift+click the upper left, my range is really from the before the HR to
the top. If clicking the HR implicitly set the caret to after the HR, this would
not happen (if I select up). Of course the implicit placement would have to be
before the HR if I selected down.

Comment 7

16 years ago
marking this as dependent on 56401. the patch in 56401 will fix this problem as
well.
Depends on: 56401
(Assignee)

Comment 8

15 years ago
-->brade in case this reopens
Status: ASSIGNED → NEW
(Assignee)

Comment 9

15 years ago
-->brade
Assignee: mjudge → brade
(Assignee)

Comment 10

15 years ago
this seems to work for me now; resolving as fixed (by patch in bug 56401 as
mjudge anticipated)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.