[Shadow-DOM] Only <button> elements receive 'click' events

VERIFIED DUPLICATE of bug 887541

Status

()

Core
DOM
VERIFIED DUPLICATE of bug 887541
3 years ago
3 years ago

People

(Reporter: wilsonpage, Assigned: wchen)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.1-feature-qa+])

(Reporter)

Description

3 years ago
In the world of the Shadow-DOM only <button> elements receive clicks. Projected content always receives clicks (no matter what tag), and clicks will propagate to non <button> elements, so long as the event.target is a <button>.

EXAMPLE

http://jsbin.com/cigac/7/quiet
(Reporter)

Updated

3 years ago
Blocks: 811542
Depends on: 1026047

Updated

3 years ago
Depends on: 887541
(Assignee)

Updated

3 years ago
Assignee: nobody → wchen

Updated

3 years ago
QA Whiteboard: [2.1-feature-qa+]

Updated

3 years ago
QA Whiteboard: [2.1-feature-qa+] → [2.1-feature-qa-]

Updated

3 years ago
Whiteboard: [2.1-feature-qa+]

Updated

3 years ago
QA Whiteboard: [2.1-feature-qa-]

Updated

3 years ago
Flags: in-moztrap-
Andrew - Is this still planning to happen in 2.1 or is this being moved to a future release?
Flags: needinfo?(overholt)

Comment 2

3 years ago
Shouldn't this be fixed now?
Flags: needinfo?(wilsonpage)

Comment 3

3 years ago
Ah, wilson is on pto.
Flags: needinfo?(wilsonpage) → needinfo?(wchen)
(Assignee)

Comment 4

3 years ago
I tested with nightly and all the event stuff is working as a result of bug 887541.
Flags: needinfo?(wchen)
William - Should we close this then?
Flags: needinfo?(overholt) → needinfo?(wchen)

Updated

3 years ago
QA Whiteboard: [2.1-feature-slip?]
(Assignee)

Comment 6

3 years ago
Yeah, this bug should be closed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(wchen)
Resolution: --- → DUPLICATE
Duplicate of bug: 887541

Updated

3 years ago
QA Whiteboard: [2.1-feature-slip?]
No QA planned, so marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.